Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After speeding too much time trying to find out what went wrong with the installation of a new module in python, I realised that the root of the problem is due to fault configuration of PyDev plug-in. On the contrary, the same module works fine in IDLE 3.2. So my question is: how could I configure PyDev with exactly the same settings as IDLE 3.2???

share|improve this question

1 Answer 1

I don't know if you still have this problem, but I'll leave the answer anyway (just in case someone else comes across the same problem - like I did a few days ago).

From this tutorial:

To configure the interpreter:
1. Go to: window > preferences > PyDev > Interpreter - (Python/Jython/IronPython).
Note that the Auto Config will try to find it in your PATH, but it can fail if it's not there (or if you want to configure a different interpreter).
On Windows it'll also search the registry and provide a choice based on the multiple interpreters available in your computer (searching in the registry).
On Linux/Mac, usually you can do a 'which python' to know where the python executable is located.

2. Choose the interpreter you have installed in your computer (such as python.exe, jython.jar or ipy.exe).

3. Select the paths that will be in your SYSTEM PYTHONPATH.
IMPORTANT: Select only folders that will NOT be used as source folders for any project of yours (those should be later configured as source folders in the project).
IMPORTANT for Mac users: The Python version that usually ships with Mac doesn't seem to have the .py source files available, which are required for PyDev, so, using a different interpreter is recommended (i.e.: Download it from http://python.org). If you don't want to use a different interpreter, get the source files for the Python '/Lib' folder and add those to the system installation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.