Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed [insert favourite text editor here] and associated it with all file extensions which by default open with notepad.exe. Still, there is a context menu entry Edit e.g. on *.txt files which still brings up Notepad.

How can I change this context menu entry to also open my editor instead of Notepad?

share|improve this question

migrated from stackoverflow.com Nov 26 '12 at 15:50

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 2 down vote accepted

There are two places in the Windows registry that define context menu entries:

  • File extension

    For *.txt files, the default value of HKEY_CLASSES_ROOT\.txt points to HKEY_CLASSES_ROOT\txtfile, which defines the context menu entries

  • Perceived type

    *.txt files have a perceived type text (see PerceivedType property in key HKEY_CLASSES_ROOT\.txt), and that type defines its context menu entries at HKEY_CLASSES_ROOT\SystemFileAssociations\text

If you also change the commands for the perceived type text, you should always get your favourite editor for all text files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.