Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a ThinkPad T510 laptop with Gentoo Linux installed on it and I can’t manage to get VGA and DisplayPort working. xrandr -q won’t show them, so I’m guessing, that there’s a problem with my kernel configuration, but I wasn’t able to find the options responsible for these ports. Here’s the output from xrandr -q:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 175, current 1366 x 768, maximum 1366 x 768
default connected 1366x768+0+0 0mm x 0mm
   1366x768       50.0*    51.0     52.0  
   1024x768       53.0     54.0  
   832x624        55.0  
   800x600        56.0     57.0     58.0     59.0     60.0  
   720x400        61.0  
   700x525        62.0  
   640x512        63.0     64.0  
   640x480        65.0     66.0     67.0     68.0     69.0  
   640x400        70.0  
   640x350        71.0  
   576x432        72.0  
   512x384        73.0     74.0     75.0     76.0     77.0  
   416x312        78.0  
   400x300        79.0     80.0     81.0     82.0     83.0  
   360x200        84.0  
   320x240        85.0     86.0     87.0     88.0  
   320x200        89.0  
   320x175        90.0

Can anyone help me figure out what the problem is and how to get the video connections to work?

UPD:

Problem seem to be resolved on its own. After planned update, that included updating xorg I know have my DisplayPort working and I think VGA as well.

What I did:

Update x11-base/xorg-server (mine is 1.13.0-r1 now) and all dependencies and do this with sudo or as root:

emerge -av -1 $(qlist -IC x11-drivers)

Command above should also reemerge your video driver(nvidia-drivers in my case, version 304.64). That's basically it, now my xrandr -q looks like this:

Screen 0: minimum 8 x 8, current 3286 x 1080, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS-0 connected 1366x768+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
   1366x768       59.6*+   50.0  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)
share|improve this question
    
Do you mean you want both the VGA and displayport outputs working simultanously? Have you confirmed this is supported in general? –  Paul Nov 27 '12 at 4:05
    
@Paul no, I want them just to work. To be honest, I haven't tried to link VGA monitor with it, but if I know correctly, if xrandr doesn't show any information about VGA port it won't work. I tried DisplayPort, but it didn't work and xrandr output didn't change when I connected it. –  Psyhister Nov 27 '12 at 13:58
add comment

1 Answer 1

Please file a bug at http://bugs.gentoo.org and include:

  • emerge --info sys-kernel/gentoo-sources in first comment, if it is too big, as attachment.

  • Versions of gentoo-sources, xorg-server, xrandr and your drivers in your first comment.

  • dmesg output, as an attachment.

  • /usr/src/linux/.config, as an attachment

  • /var/log/Xorg.0.log, as an attachment

  • xrandr --query --verbose, as an attachment.

Since I'm wrangling both new and kernel bugs I will come across your bug, I'll update this question with more details (and if we found it, the solution) so others that find this can benefit as well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.