Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the software CORD 0.5.7 on my Mac (OSX 10.7) as a RDC client for accessing various Windows servers. However since one of the latest updates of the software the Copy and Paste behaviour has changed. It only works ONCE, then after restart it works ONCE again. So if I wanted to do several C&P actions I need to restart the program in between each C&P. This is not a very good production environment...

Do anyone have a clue what might be the problem? Is it CORD or other system change that might be the problem?

share|improve this question
    
I'm running OSX 10.7.5, and Cord 0.5.7 (5701) and unfortunately couldn't replicate your issue. I was RDP'ing into a Windows 7 Professional box. I'm not sure if this is a problem with Cord or the machine you're connecting to. Keep in mind in OS X you use CMD+C/V but in Cord (rdp'ing into windows machine) use CNTL+C/V. Considering you can make it work once, you probably already know this. –  BrenanK Nov 28 '12 at 7:37
1  
@BrenanK Thank you for your suggestions. Well we have the problem in a quite large scale, on about 10 client computers (both OSX 10.7 and 10.8) so its not just a single setup. However we are only connecting to Windows 2003 servers so I haven't tried Win7. The (un)funny thing is that it worked flawlessly until a recent update of CORD (from 0.5.6 or 0.5.5?) so it just might be a compatibility problem with the software. Now we're using MS RDC for mac when we have to C&P a lot... –  jtheman Nov 28 '12 at 12:22
    
Interesting, I can definitely see how that would be a pain. As a side note, I also noticed the dns lookup does not check the hosts file. "localhost" does not resolve to 127.0.0.1 like it should. Looks like the most recent update is a little buggy in general. –  BrenanK Nov 28 '12 at 21:01
    
Same here: CoRD on a Retina MacBook Pro 0.5.7 to various versions of x86 and x64 Windows (XP, 2003, 7, 8). For none the clipboard works reliably. The good thing though: Command-key is forwarded properly (: –  Jeroen Wiert Pluimers Jun 24 '13 at 10:46
    
@jtheman If you can still reproduce it, please add information to this issue report: github.com/dorianj/CoRD/issues/2 –  Jeroen Wiert Pluimers Jun 24 '13 at 14:12

2 Answers 2

up vote 1 down vote accepted

For some people the custom post 0.5.7 build of CoRD found at http://github.com/jonnybergdahl/CoRD/downloads solves this problem.

You can find more about that build in this thread on the sourceforge forums: http://sourceforge.net/apps/phpbb/cord/viewtopic.php?f=1&t=187&p=1117#p1117

That build is by jonnybergdahl, one of the CoRD developers.

share|improve this answer

After long research, I found this solution: Copy pasting and clipboard not working in Remote Desktop (RDP)

Basically, killing rdpclip.exe and restarting it from Start > Run > rdpclip.exe copy&paste working again.

share|improve this answer
    
That solution (actually, a kludge) might work on windows, but the OP is using OS/X. –  Hennes Feb 23 '13 at 13:31
1  
Well it works if I kill the clip process on the Server side (Windows). But still not a solution for our users as it's just another workaround and more or less just as complicated as disconnecting and restarting the client. Note that this problem wasn't around until a year ago, before that we have been running the environment for 4-5 years. –  jtheman Feb 23 '13 at 23:30
    
Killing RDPCLIP.EXE makes it only work once for me: from Mac to Windows (the other way consistently fails). CoRD 0.5.7 on Retina MacBook Pro. –  Jeroen Wiert Pluimers Jun 24 '13 at 10:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.