Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We just migrated one of our sites to Windows 7 and suddenly 2 PCs started having a wierd issue. A USB device suddenly starts connecting and disconnecting non stop with the usual "Ding Dong" sound.

I first thought it was a rogue USB key but I have disconnected all USB devices from the desktop and it is still doing it even with nothing connected. Even started uninstalling the USB drivers one by one and restarting the PC. This is constant at least 3 times a minute.

Any suggestions?

share|improve this question

if you right-click on the speaker icon by the clock and choose "Open Volume Mixer", it will show what's making sounds

if you can't find any other answer, you can at least mute the spurious ding/dong

share|improve this answer
    
I have disabled the Device Connect Disconnect sound however its a Per User setting so I must write a script for this temp workaround. Still looking for an actual solution though – Arturski Nov 28 '12 at 16:20

It sounds like it could be a virtual drive that is being recognized as a peripheral like a camera or sandisk. It is also possible you have a bluetooth or wireless device that is trying to connect to the PCs.

If you have any virtual drive software then try uninstalling it. Also, have a look in "Devices and Printers" to see if anything is showing up there.

If all this fails and you still have the dingdong sound then you could be looking at a faulty usb port. Try to see if any of the ports are not working by testing them with working usb keys - you may be able to identify the offending port. If uninstalling the drivers doesn't let you turn off the port then you should be able to turn them off in the BIOS.

If you still cannot find the problem then your last option will be to turn off the dingdong by going to Control Panel > Sounds > Sounds - highlight Device Connect and chose none.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.