Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Around 12 months ago, When my Windows 7 PC boots up, Notepad started to appear automatically on the desktop (as a duplicate ie one on top of the other), both displaying the same writing inside, and the name of the Notepad was: desktop-Notepad.

[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

I cant remember the exact details as its been so long now but a friend told me, this was due to a "hidden attribute" belonging to notepad becoming "unhidden"and therefore allowing notepad to show itself on the desktop at startup. He showed me a series of steps to either hide the attribute again or to delete it ( telling me that upon restart of my computer it would be recreated/regenerated.)

I did indeed follow his guidance however after trying to hide it or delete the attribute (it was never recreated after restart which supposedly it should have done)

One notepad still is autolaunched with the text as shown above everytime I startup my PC. As I found this forum I thought I might try again for a solution to prevent notepad from launching.

Thankyou

share|improve this question
1  
This is the classic signed that you are or were infected with Malware. –  Ramhound Nov 27 '12 at 11:09
    
@Ramhound - No I dont believe that to be the case. What I was told 12 months ago, by my friend is that Microsoft has admitted there to be a bug in the Windows OS that also shows itself in Windows 7 - this concurs with the answers given by Paul and Dave below –  Simon Nov 27 '12 at 11:26
    
@Simon, what malware removal program have you used though to rule this out? Many bugs / errors that occur can be similar to other bugs / errors - so although it looks like one thing (a MS bug) it doesn't mean it IS a MS bug, so let's rule it out; Malwarebytes should suffice. –  Dave Nov 27 '12 at 12:14
    
@DaveRook at the time I was using Avast Pro, Private Firewall in addition to Malwarebytes Antimalware, Spyware Blaster & Dr Web On Demand Scanner. The only difference is now I have been using NIS for the past 3 months I guess in stead of Avast Pro. I have always been conscious of running regular scans. Yes MBAM is an excellent program which I probably run at least once a week if not more –  Simon Nov 27 '12 at 12:40
    
@Ramhound - My apologies Ramhound, yes it could well have been a virus, I was a bit blunt with you. Since I have a good arsenal of weaponry(i believe), I thought the problem was deeper. Had it been one notepad appearing then the solutions given i'm guessing would have worked but one still remains. Again not currently at that PC so cannot make further comment –  Simon Nov 27 '12 at 13:15

2 Answers 2

up vote 1 down vote accepted

This is an old problem from Windows XP which also occurs in some Windows 7 versions. A step-by-step solution is here: how-to-fix-notepad-opens-randomly-by-itself-on-windows-7

  1. Click Start.
  2. Click Computer.
  3. Click Organize located on the left side of your Windows 7 upper toolbar.
  4. Click Folder and Search Option.
  5. Click the View tab.
  6. Under Hidden Folders and Files, click the Show folders, files and drives radio button.
  7. Click OK and exit.
  8. Now, click Start.
  9. In the Search field, type desktop.ini and press Enter.
  10. Alternatively, you can also go to: C: - Program Data - Microsoft -Windows -Start Menu -Programs – Startup folder.
  11. Right-click it and delete it.
  12. Now go to: Go to C: - Users – Your_Username - AppData – Roaming – Microsoft – Windows - Start Menu – Startup folder.
  13. Again, delete the desktop.ini file.
  14. Done! This should stop your notepad from opening by itself!
share|improve this answer
2  
You just beat me to it - I copied my answer into yours - please don't just link though, always copy the content as links stop working :) –  Dave Nov 27 '12 at 10:33
    
@Dave Rook- Dave thats right desktop.ini file, when I did delete that 12 months ago. It only stopped 1 Notepad from launching (I had 2 appearing on the desktop), 1 still remains. I have to go out now so I cant test anything - be back in about 8 hrs –  Simon Nov 27 '12 at 10:38
    
@Lee Taylor - I did the above 12 months ago, the destop.ini file is the attribute that had become unhidden. I think this solution would have worked if there had been only one notepad appearing. It did indeed remove, however one notepad still is autolaunching at startup. From what I recall I went to look for that desktop.ini file on a number of occasions (at the time 12 months ago) and it has been deleted. I am currently away from home computer and cannot check at this present time. So when I am able to check I will. The "problem" is deeper than that. When I can check that folder later I will –  Simon Nov 27 '12 at 12:05
    
@Simon - your comment is aimed at Lee Taylor - please note, Lee only edited the post, it was originally created by Paul and as such you probably want to use the @ with Paul's name :) –  Dave Nov 27 '12 at 12:12
    
@Lee Taylor - My apologies. I'm new to this. Its an amazing forum. Thx –  Simon Nov 27 '12 at 12:44

Although Pauls' answer may solve this, when programs (this is broader than just notepad) load up at start up you can also look at:

MSCONFIG

Open run command and type msconfig - in the start up tab make sure it is not selected (nor any unusual programs which could be causing this).

Scheduled tasks

Open task scheduler from the control panel and look through each task to see if any are to launch on start up.

share|improve this answer
    
Thanks for the suggestion Dave, I know about startup items relating to MSCONFIG, I have a program called Soluto which monitors these. Again will check when I get home :) –  Simon Nov 27 '12 at 12:08
    
I have checked the startup items in MSCONFIG, thee is no reference to notepad there. I have also checked the task scheduler and there is also no reference to notepad there either. I have gone through the steps outlined below however at step 12 there isnt a start up folder to delete within the start menu –  Simon Nov 27 '12 at 17:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.