Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We had an old Laptop (Windows ME) whose only USB device had stopped working. Since the only working drive remained was a floppy drive, I bought an USB house, extracted the hard disk from the PC, put it in the house and connected it to my Windows 7 laptop to get out anything old which might be of interest; we guess that there are some older digital photogaphs on the laptop.

Reaction time was very slow, but maybe that’s common for USB harddisks. We didn’t find anything of interest at a first glance. Some folders could not be opened at all in reasonable time, though the drive worked hearably. Surprisingly, a larger amount of pages saved from web and some other stuff was placed right into the root folder (former ‘C:\’): NTFS bug or bad user behavior? I don’t know.

I tried copying ‘everything’ onto my hard disk (giving it the night) but Windows’ copy dialog simply disappeared after about two seconds without any message. I tried manually copy of some singelton .doc files, some worked, some caused errors, so I then ran ScanDisk on the drive. It came quite far within two hours, had checked more than 5,000 files, and hung. After a reboot Windows doesn’t recognize the file system any more. It appears as a drive, but cannot be opened. What is my issue? (Corrupt disk? Corrupt USB connector?) And how to go on? Is there something left to recover?

share|improve this question
Not likely an NTFS bug. Windows ME did not support NTFS. Like the answerer said, it sure appears you have a flaky hard disk. – MJZ Dec 14 '12 at 2:13
up vote 0 down vote accepted

It sounds to me like you have a bad hard disk. Try disconnecting the drive and reconnecting.

Look under my computer to see if it shows up, if not then open up command prompt and type the following


Once Diskpart has loaded in cmd, run the following command

List disk

That should list any hard drive that is connected to your computer whether internally through SATA or through a USB connection. Try and find your disk, you should know the size of the drive and Diskpart will tell you the sizes of the drives it finds, it it sees the drive then try running the following commands

Select disk 1

(instead of 1, use which ever number the drive that you are having problems with)

List partition

That should show you a list of partitions on the drive again if it even allows you to see it.

If you do happen to gain access to the drive, i would use command prompt to copy your data instead of copying and pasting files using xcopy:

For example:

xcopy C:\*.* D:\Data /s /e /h

Thats just a small example if you didn't know how to use xcopy.

share|improve this answer
Vote Up requires 15 reputation … thanks anyhow! – Paramaeleon Nov 27 '12 at 15:44
Thanks, I didn’t knew the tool. Recovering the partition however failed. I reformatted it with Fat32 now and there are no bad sectors…⁇ Anyhow, I won’t use that disc for anything serious any more… ☺ – Paramaeleon Dec 14 '12 at 10:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.