Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently noticed some performance issues after moving to Windows 8 and saw that the Catalyst Control Center wasn't working (didn't update it after upgrading to Windows 8). Whenever i manually open the CCC it only shows me preferences for my CPU but shows me nothing concerning my graphic card.

I deinstalled the drivers, all of the AMD software on the PC, rebooted and tried to install the newest Version (12.10) which didn't show me any errors, but the situation remained the same as before.


  • 2x AMD Radeon HD 5770
  • Windows 8 (64-Bit)


other Screenshots of the issue:



Thanks for your time and help!

share|improve this question
try the 12.11 Beta 8 driver which has a lot of fixes (pool memory leak) in Windows 8:… – magicandre1981 Nov 27 '12 at 14:02
doesnt work either. It seems as if it doesnt even install the drivers, although the installation ends without any errors... Tried 12.6, 12.11 beta8, 12.10 and none of them work. I even cleaned all the drivers with driver sweeper but that didnt work either – algorithms Nov 27 '12 at 20:08
ok got it to work now by manually installing the driver. Apparently the installer wasn't able to do so... – algorithms Nov 27 '12 at 20:20

For some reason my brand new Windows 8 machine had the same problem. Despite installing much newer drivers it kept not completely updating. I only noticed by rigorously testing different games to see the performance problems. Ultimately I solved this by installing the latest AMD beta drivers and then forcing an update of the graphics drivers through device manager.

As of this writing, the latest beta drivers were here: I installed this driver first and restarted.

Once back logged in, I hit Win + X to bring up the admin context menu and selected "Device Manager." I went to display adapters, picked my card, right click, and selected properties. In that window you can click "Update Driver." Once I updated this I restarted the computer again.

Once back logged in, I hit Win + D to bring up the desktop. I right-clicked and chose Catalyst Control Center. This time it came up with my graphics settings and had an updated driver.

share|improve this answer
up vote 0 down vote accepted

Solved it through manually installing the driver. The automatic intaller you download from AMD s Website doesn't seem to be able to install it on its own. Could also be a problem with the Windows 7 -> Windows 8 Upgrade process.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .