Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the CentOS 6.3 Live DVD x64 version; however, I can only access Google and IPs living on my LAN (haven't tested external IPs) in Firefox and Konqueror. Yum can't access mirrors as it claims sub-1kb/s speed and Xchat can't completely finish connecting to servers. I've tried this (trying to use the instruction given make NM unable to connect to the internet, regardless of DHCP with custom DNS or static, with or without custom MTU)

#centos was completely useless, they think it's a memory problem (yeah right... 1 GB isn't a lot, but it's not the problem)

My other specs: SiS 191 GBE networking, connecting over a DD-WRT wireless bridge on a WRT54G router connecting to an Actiontec R1000H router.

share|improve this question
add comment

2 Answers

Try Using IPTables to do MTU clamping or reducing the MTU on your network interface. You can do this with the command

iptables -I INPUT -p tcp --tcp-flags SYN,RST SYN -j TCPMSS  --clamp-mss-to-pmtu

I suspect this will work as from the sounds of things your Internet connection is kinda working to some places and often gives slow speeds, and this is consistent with MTU size issues. (MTU being the size of the packets sent. Sometimes things like VPN's or even your ISP doing encapsulation of IP in another protocol) can cause issues. MTU clamping, while a hack, is a very widely used hack.

You will probably find that the sites that work have a lower MTU on their side, or are doing MTU clamping for you (or are sending less then 1500 bytes back to you).

share|improve this answer
    
I REALLY don't want to run a firewall on my system. I run no exposed servers on it. I've given up on this a long time ago as I'll just run Debian. It works. –  Calvin B Feb 26 '13 at 20:18
    
Thats your perogative (I personally think that is a naive attitude). I would also point out that using IPTables to clamp MTU does not imply any kind of firewalling, even though iptables is used primarily for that purpose. You may be able to "get round" the problem by setting a lower MTU on your ethernet interface. –  davidgo Feb 26 '13 at 22:47
    
It's been a while, but I did change the MTU settings for the ethernet interface. It failed, as I mentioned in the question. –  Calvin B Mar 9 '13 at 16:15
add comment
up vote 0 down vote accepted

It turns out that I needed to set yup MTU manually like:

ip link set eth0 mtu 1496

It seems to work really nice on Debian.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.