Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It's not that I'm trying to make it more like 7. That's not the problem.

My problem is that whenever I click the Google Chrome icon on my taskbar or even the desktop, Windows brings up this screen-spanning message box saying that my resolution is too low to launch run Google Chrome, and to set my computer to a higher resolution. (I can't.)

It then continues to open Chrome correctly after I hit close. This also happens when I click a link in an external program like skype or psi.

Update: Now it never launches. I tried to get into my gmail through it this morning, and it won't launch at all.

share|improve this question
    
I notice, specifically when opening a new chrome window via Win+Shift+<TaskbarIndex> (Chrome is the second icon in my taskbar so I use the keyboard key '2'). This issue started for me on or just before 2014-12-06 –  ThorSummoner Dec 7 at 7:19

9 Answers 9

Click the menu button in the top left. There should be a "Relaunch Chrome on the Desktop" item, like this:

1

share|improve this answer
1  
Nope. Mine says "Relaunch Chrome in Windows 8 mode". It's the actual attempt to launch it when it's closed via desktop icon that tries to do the opposite. –  Citrus Rain Nov 27 '12 at 23:46
    
kerdek: To make [this] answer work, you must either have UAC disabled (NOT in silent mode; Win8 will trick you here) or you must run chrome as an administrator after ending all chrome background processes from within Task Manager. –  Canadian Luke Dec 12 '13 at 19:54

Since coggy9's answer did not help (it should have), try appending the --force-desktop flag to the Target field of the Chrome shortcut's properties (such that it looks like chrome.exe --force-desktop).

Something like the following (but with the --force-desktop flag obviously instead of --incognito as shown):

1

share|improve this answer
    
it accepts --incognito, but not --force-desktop –  Citrus Rain Nov 28 '12 at 21:01

In the Google chrome install directory, there there is an exe for the metro app and an exe for the traditional app. I added the traditional exe to my desktop taskbar (launcher), and pinned it to the metro menu, and unpinned the metro version. So I can open it by either way without ending up with the metro version.

share|improve this answer
    
Sorry, I double checked and this no longer works. This is how I did it when Windows 8 launched. It seems at some point the exes were harmonized. Coggy9's solution works for me, and it remembers your last launch option (once you go to desktop it always launches in desktop unless you relaunch in metro). –  kashiko Dec 1 '12 at 2:57
    
I placed the traditional exe on my desktop originally. Now there's only the one. –  Citrus Rain Dec 1 '12 at 18:49

I noticed that if you launch an incognito window, and leave it running, you can then run the regular chrome browser from the desktop. It will still complain about the resolution, but it will start.

share|improve this answer
    
Doesn't help when it crashes or if it hasn't been started yet. –  Citrus Rain Jan 22 '13 at 2:29

Just go to the chrome installation path like this (C:\Program Files (x86)\Google\Chrome\Application\24.0.1312.52) and click chrome_launcher. Now Chrome will be open in Windows 8 mode, click on Customize icon and click Reopen in desktop mode. That's it.

share|improve this answer
  • Open regedit, navigate to HKEY_CURRENT_USER\Software\Google\Chrome\Metro and delete the field launch_mode or set the value from 1 to 0.
  • Open chrome.
  • Be happy.

On my register, there was not a field called launch_mode. So, I created it and put in the value "0", and this works like a charm!

share|improve this answer
    
Both setting to zero (it was already set to zero) and deleting the registry value didn't work. Chrome still launches new windows in metro mode. –  ThorSummoner Dec 7 at 7:09

None of the previous answers worked for me. However, I've noticed that in the programs folder for Google Chrome there was a "metro_driver.dll" file (without the quotes). What I did was to rename this file as "metro_driver.dll.bak" (without the quotes). After that, whenever I start the Chrome browser I don't receive the message saying the app can't be opened and Chrome starts right in desktop mode.

The folder path for Google Chrome on my device is:

C:\Program Files\Google\Chrome\Application\30.0.1599.101
share|improve this answer
    
For me, chrome still launches in metro, then crash/exits leaving me on the metro menu. :( –  ThorSummoner Dec 7 at 7:14

If you ever get this problem on a macbook running bootcamp and the retina screen screws up your resolution so that you can't access the settings menu to "change to desktop" view, then go into control panel and adjust your resolution to close to the smallest, and then things should all appear when you launch chrome in the now metro mode. it might help to ctrl+alt+delete and close chrome completely then re-open. once everything is fixed, you can bring your resolution back up. cheers.

share|improve this answer

What I get is that sometimes a link I click in from Chrome in desktop mode will try to launch in Metro. Also, sometimes a desktop app requesting a website will try to launch in Metro. This I do not want.

What I have tried and seems to be working, though I can't say with complete certainty as it is sporadic was to go to chrome://flags then Touch Optimized UI and change the value from Automatic to Disabled.

share|improve this answer
    
Welcome. On a forum site, it is common to contribute anything that might be helpful, like your answer. This is a question and answer site designed to compile high quality questions and answers for reference. One of the standards for answers is that they be definitive, so anyone seeing it in the future will be assured it works. Since you aren't sure about your solution, it doesn't make a good answer. Since it might be helpful, the appropriate place for it would be a comment. You don't yet have enough rep for that, but stick around, contribute appropriately, and you soon will. –  fixer1234 Nov 11 at 4:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.