Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason, the IP addresses of devices connected to my second router are invisible to the system connected to the first router. For the second router however, I can view the systems connected to the first. Also, I can't view the router's index page from a computer connected to the first but can view both from the second. I suppose there's probably a networking fundamental I've missed here.

share|improve this question
    
Instead of describing the circumstances in the abstract, please provide an example (with IP addresses, subnet masks) of what doesn't work. –  sawdust Nov 28 '12 at 2:57
    
Probably hitting a NAT Problem. @wbeard52 s solution should take care of that problem. –  PsychoData Jan 28 at 0:03

1 Answer 1

It sounds like you plugged a cable from the LAN side of the first router to the WAN side of the second router.

An easy way to test. Are the first three digit groups of the IP address the same on all your computers (regardless of which router they are plugged into)? If they are different then I am 100% sure that what I said is the case. Plug the cable connecting the two routers to the LAN side of each.

Before you do that though, you will need to go into the index page of the second router and turn off DHCP and statically set the second routers LAN IP address to an address in the range of the first router. Effectively, you are disabling the router part of the router and making it a network switch which is probably what you need anyways.

share|improve this answer
    
Sounds like a perfect example of a NAT issue. NAT translates your traffic going out to the first router mgmt page and un-translates the responses back to your machine (off R2). And all the routers off R1 can only see the one outer facing address of R2. –  PsychoData Jan 28 at 0:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.