Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Asus UX32VD that was recently purchased. Amongst other headaches, like F9 to restore not restoring, GPT and UEFI I have a booting issue that I would like to try and resolve.

I lost my factory install due to using a partitioning tool that did not understand GPT properly, this also goosed the restore partition so a failed boot as well. F9 is a joke. After using a dodgy torrent to get back my restore partition/ boot loader/ manager I was then able to build a bootable WinPE flash using the ADK that allowed me to use imagex to expand the factory restore image back to the original partition. Voila, working factory install again, at least for now.

Now what I actually want to do is to have XP, Win7, Win 8 and Ubuntu, so I have dumped GPT, and repartitioned using Diskpart. So far so good.

Getting an MBR boot on the UX32VD was trickier than I thought, it auto defaults to UEFI from the factory and there's no obvious switch in the Bios as such to change that. However after chasing my tail for a few days, I discovered the answer. To enable normal MBR booting you Enable CSM in the boot tab and Disable "Secure Boot" on the security tab of the Bios/ Setup. Hopefully this will save someone else the headache...

So everything has gone well with the exception of my original factory Win 8. I need some ideas on how or what to manipulate/ configure on the factory image so that it will allow an MBR boot. Bearing in mind that I don't have a setup disc, only the factory wim image that obviously expects UEFI boot.

Anyone care to take a stab at it?

share|improve this question
    
I think all images are prepared for UEFI and BIOS boot. Look for winload.efi and for winload.exe in image - should be present in \Windows\System32\Boot (or whatever is specified as path to WinRE loader). ReagentC utility can help you put a boot entry for WinRE. –  snayob Nov 28 '12 at 10:27
    
That sounds promising. I have never used the ReagentC tool before, and after trying to get a handle on it and the WinRe, I'm probably more confused now than anything, so any help in that direction would also be welcome :>) I assume that using this tool I should be able to just add the path back to the windows loader on the partition containing my applied image? –  user176482 Nov 28 '12 at 13:17
    
Boot process with MBR disk -> 1. MBR loaded. 2. Active partition boot record loaded. 3. boot manager loaded (uses BCD). All boot config data is in BCD. I will post a longer explanation as a separate answer. –  snayob Nov 30 '12 at 15:30

2 Answers 2

Firstly whether you are using BIOS or UEFI is irrelevant of the partition (MBR/GPT) type of your hard drive.

Secondly, this is determined by Windows during installation. Since you have the WIM file, which is basically a captured image of the Windows partition, your best bet is to create a USB with the recovery environment on it but make sure to include ImageX.exe. Boot into WinRE and expand your WIM, from the command line using ImageX. You can try use the automatic options to repair the MBR and that should work.

Failing that you can use the bootrec.exe tool.

bootrec.exe /fixboot    
bootrec.exe /fixmbr
bootsect.exe /nt60 all /force

Note: These are just suggestions from my experience, i have not tried them in your situation.

share|improve this answer
    
Thanks everyone for the pointers, I appreciate it. I have tried applying the original factory image over the dodgy one, both from WinPE and the WinRE command line, I have used bootsec and bootrec without much success. I did notice that, despite having three different versions of windows on various partitions on the drive, bootrec /scanos reports that it found 0 installations, so there's no way to get it to rebuild the BCD either. I'll keep plugging away with it, I'm sure there has to be a way to untangle it and get my original factory image to boot. –  user176482 Nov 29 '12 at 15:39
    
If anyone has some more things to try, I'm happy to be the guinea pig! I don't have anything on the machine other than bare O/S installs, at the moment, so I can happily experiment without losing anything :>) –  user176482 Nov 29 '12 at 15:39
    
@user176482 - You should try this way before you ask for additional ways. –  Ramhound Nov 30 '12 at 16:13

Boot process with MBR disk:

  1. MBR loaded.
  2. Active partition boot record loaded.
  3. Boot manager loaded (uses BCD). All boot config data is in BCD.

In BCD there are usually 3 loaders for a single Windows Vista/7/8 OS:

  1. "base" loader for OS
  2. resume loader for OS (created automatically by Windows)
  3. recovery loader for OS

Recovery loader is linked by an element ("RecoverySequence") in "base" loader so when you type F8 (advanced boot options) you can select "Repair computer" => recovery loader which loads WinRE.

Resume loader is also linked by an element ("AssociatedResumeObject") in "base loader".

Things are very well displayed in Visual BCD Editor - a complete BCD GUI editor.

Using ReAgentC utility you can create a recovery loader (and link from base loader to recovery loader). First You specify where the .wim image is with "reagentc /setreimage and full path to .wim". Then you use "reagentc /enable" => loader and link are created in BCD. When you use "reagentc /disable" the recovery loader is deleted and the link is destroyed.

You use reagentc in the context of current OS so current OS loader is target of the command.

You can start by installing Windows 7 image on empty hard disk by using imagex. You create a primary partition and make it active then put image to it. Then use:

  1. bootsect.exe - to write MBR and PBP
  2. bcdboot.exe - to create boot environment (bootmgr + BCD)

Hope this helps.

share|improve this answer
    
That certainly helps my understanding of the ReagentC tool, however when using it I seem to get unknown error 3 when trying to specify where the .wim image is located. –  user176482 Dec 6 '12 at 12:39
    
I have however bungled my way through to a solution. I installed my dodgy torrent to get a working recovery and boot partition, then applied the .wim over the top of it using imagex. I started a WinPE session and run bootsect and bootrec. I then rebooted but held F8 and selected safe mode. During the boot I got an error telling me that setup cannot run in safe mode to reboot. Upon reboot setup magically appears again out of nowhere and I get presented with my personalization screens (oobe) and finally my legit copy of windows 8. –  user176482 Dec 6 '12 at 12:53
    
I don't exactly know where setup comes from, I'm just glad it's now working :>) Thanks to everyone for your help :>) –  user176482 Dec 6 '12 at 12:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.