Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently experimenting with irssi as my irc client of choice and I'm getting along pretty well.

BUT there is one thing I still need to get done. Somehow it isn't possible for me to use the usual CTRL+Left/Right to navigate between words in my input line.

For the record: I'm using irssi on a linux-box through a screen session brought to my windows machine via ssh/putty.

I already tried some key binding in irssi, maybe I did them wrong?

/bind meta-n backward_word
/bind meta-m forward_word

both work fine. But neither

/bind ^left backward_word
/bind ^right backward_word

nor

/bind cleft-left backward_word
/bind cleft-right backward_word

work for a CTRL+Left/Right setup.

Any Ideas?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

First: perhaps Shift+ and Shift+ work as substitutes.

But for the problem in hand: it's most probably some input anomaly, where some part of the chain is not really aware of what "language" others are talking. With PuTTY in the mix, this is not unexpected.

A practical way to solve it:

  1. Issue cat in a terminal without arguments and press Ctrl+.
  2. Paste the entire keycode that occurs (^[Od in my case but most probably something else for you since it doesn't work by default) into the irssi bind command:

    /bind yourkeycode backward_word
    

Now it should work. If not, make sure the binding isn't trumped by any else by issuing /bind and see if there are multiple entries.

I use the exact way described above in binding Ctrl+PgUp and Ctrl+PgDn to scroll an external nick list in irssi.

share|improve this answer
    
I noticed that, inside screen, the sequences displayed by cat are the same for Ctrl + ← and ← . So I guess screen kills the control sequence. I'm going to use Alt + ← now, that still works. Thank you for the hint with cat. –  vikenemesh Nov 28 '12 at 12:07
    
@vikenemesh: Ah, yes, if separate key codes are not sent, then it is not possible to fix it within irssi. Perhaps there is some PuTTY setting that could help you to make it send meta character combinations correctly, though, but that's another question. Good of you to notice it. –  Daniel Andersson Nov 28 '12 at 13:27
    
PuTTy itself transmitts everything I need, I checked that. Screen seems to eat all Ctrl Sequences, because it can be controlled by them. –  vikenemesh Nov 28 '12 at 19:05
    
@vikenemesh: Yes, screen is also a known key code eater (I missed that part of the question). Setting the correct TERM values throughout usually fixes this, somewhat. You should at least be able to make something come through, even though it might not be directly recognized by irssi. Don't give up just yet :-) –  Daniel Andersson Nov 29 '12 at 9:06
    
I'm getting back to this if the annoyance will be unbearable, thx. –  vikenemesh Nov 29 '12 at 17:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.