Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to copy a file from Windows to Ubuntu 12.04. I have tried using the code below:

pscp C:\abc.php username@server: .

But it shows an error:

More than one remote source not supported

How to solve this?

share|improve this question

migrated from stackoverflow.com Nov 28 '12 at 10:35

This question came from our site for professional and enthusiast programmers.

Because you specify more than one remote source. username@server: . ← the dot here (which supposedly means your working directory) doesn't belong there. You cannot reference your working directory on another machine like this, and since there's a space between username@server and ., it'll be interpreted as two arguments.

Instead, specify an absolute path:

pscp C:\abc.php username@server:/home/user/foo
share|improve this answer
    
hello slhck. Thanks for your reply. I have used your code and it is displaying me error like: C:abc.php: No such file or directory. The file is there on the same location but somehow pscp command is unable to find it. and it displays C:abc.php not C:\abc.php what to do? – Jaimin Sutariya Nov 28 '12 at 10:56
    
Is that the real path you're using or just an example? Normally it should work – maybe you can give us the actual command you're using. – slhck Nov 28 '12 at 11:02

Also if you are using Windows path, chances are you may have folders/directories with spaces in them, that can cause that error as well. You may resolve this by using double quotes around your path. that was my problem

    pscp -<arguments> username@server:/home/folder/file "C:\your windows path"
share|improve this answer

I just ran into the "more than one remote source not supported" error, and it turned out it was because I was giving a file name in the destination.

I'm running on a Windows 7 box, trying to bring down a file from a Linux box. I tried:

pscp -l myusername IPADDRESS:/home/myfolder/myfilename.txt C:\Users\myuserfolder\myfilename.txt

No good.

Once I removed the filename in the target, it worked fine. This worked:

pscp -l myusername IPADDRESS:/home/myfolder/myfilename.txt C:\Users\myuserfolder
share|improve this answer

Carefully consider The space before the dot (.) in your above input "pscp C:\abc.php username@server: . " is considering as two arguments considering as two sources, It is deemed as an info and displays no more than 1 source is not supported.

Also Try follow this How to transfer files between linux and windows using putty

share|improve this answer

seems like filename in local destination not affecting. It can be present or empty.

This line worked for me (copying sql dump from remote to local):

pscp -pw ssh_pass -P 29477 ssh_user@ssh_host:/tmp/cafe.sql d:\temp\cafe.sql
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .