Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to configure port forwarding for my IP camera so that I can access it from internet. UPNP is not supported on my gateway.

My network configuration is the following:

Gateway (Ubuntu Server 12) --- Internal network  ---  ---
eth1          eth0

From my camera settings:

Gateway HTTP/RTSP port forwarding: enabled

I need to configure NAT for the RTSP connections (default port 554) and camera web panel (port 80):

iptables -A PREROUTING -t nat -i eth1 -p tcp --dport 554 -j DNAT --to
iptables -A PREROUTING -t nat -i eth1 -p tcp --dport 8000 -j DNAT --to
iptables -A FORWARD -p tcp -d --dport 554 -j ACCEPT
iptables -A FORWARD -p tcp -d --dport 80 -j ACCEPT

The problem is I can't conect neither to nor to from an outside computer.

I tried googling but haven't found anything. There are lots of tutorials how to configure SIP+RTP with NAT but not just RTSP. I don't use SIP.

How to make the port forwarding working? I would appreciate any help.

share|improve this question

On my Asus router port forwarding (ports) is enabled directly on the rounter's maintenance page. Not from the internal server configuration. Just add the service you're trying to enable and the port number same as you would for a game. Then a a green lamp comes on at bottom of the page showing that forwarding is enabled. Same thing to look for when using a torrent manager. If your game can drill through your firewall so can your camera.

My Netshare comes with a handy utility called DSL-sharing that autoconfigs the router and the PC your trying to connect to. You can get the tool from D-link.

This page contains instructions on how to setup port forwarding, also known as virtual server on a DLink router, specifically the D-Link DIR-615, DIR-825 or you can watch a video about it here.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.