Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer has started displaying all WPF apps blurry - not just text, but borders have misplaced pixels as well. For example, the right border of a certain textbox is one pixel to the left of where it should be. Resizing or moving the window has no effect.

I was able to fix this in Visual Studio by disabling hardware-accelerated rendering, but the problem still occurs in other apps that use WPF. Applications that don't use WPF are fine.

Changing ClearType settings have no effect.

The only other issue I could see, is that the diagnostics of the DirectX tests showing a spinning cube, ran really fast -- it was almost impossible to see the spinning of the cube. Disabling AGP Texture Acceleration slowed down the spinning, but now it spins much more slowly than I remember before this problem arose. But changing this has no effect on the original issue.

I am running Windows XP SP3 on an Acer Aspire 5050. Graphics card is ATI Radeon Xpress 1100.

DirectX version: 9.0c (4.09.0000.0904).

.NET versions installed:

v4.0.30319
v3.5
v3.0
v2.0.50727
v1.1.4322
v1.0.3705
share|improve this question

1 Answer 1

up vote 1 down vote accepted

It sounds like you're having a graphics card issue. The reason non-WPF programs work fine is because they aren't hardware accelerated on Windows XP.

Update your graphics card drivers, as they are usually at fault in situations like this. Whether or not the drivers fixed the problem, make sure your computer is clean (fans and heat sinks aren't full of dust or hair, etc). Do a stress test on the video card to see if any abnormalities turn up. I'd normally recommend FurMark, but it might cause your Xpress card to burst into flames, so more research on a safe stress test might be warranted.

If your card is faulty and you have no means of repairing it, you can turn system-wide hardware acceleration down to force all WPF apps to do software rendering (obviously a lame workaround, not a solution). Right click on the desktop, go to Properties, then the Settings tab and click the Advanced button. Head to the Troubleshooting tab, and turn the hardware acceleration slider back from full a notch. Restart your computer and take a look at your app again. Repeat until the glitches go away.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.