Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a spreadsheet with multiple columns and over 4000 rows. I need to sort, then alphabetize my report and everytime I do, there are 43 rows that do not sort with the rest of the report; they go to the top or bottom of the report and are alphabetized as a separate group. I've tried deleting them and re-entering them and trying all over to get them to alphabetize with the rest of the report but they continue to stay separate. Why is this happening? Any help will be appreciated.

share|improve this question
2  
We'd need to see the data to give a full answer. –  Lee Taylor Nov 28 '12 at 20:10
2  
Can we get some screenshot for that column which doesn't sort? –  Mowgli Jun 20 '13 at 14:57
    
I'm voting to close this question as off-topic because the question cannot be answered based on the information provided (other than speculation). The question is 2 1/2 yrs old, the OP never responded to requests for clarification and has not returned to SU since. –  fixer1234 Apr 7 at 2:21
    
I had some white space in front of some of my text which was keeping it from sorting properly from A-Z. –  user461925 Jun 23 at 21:00

9 Answers 9

Sounds like those 43 rows each has a column with a leading blank. Blanks precede printable characters in common sorting algorithms. That would account for the behavior you describe.

share|improve this answer

This can also happen if you create a filter, then add new data. Try removing the filter and sorting again.

share|improve this answer

I just encountered a similar issue. The answer ended up being that some of my cells in the sort column were entered as text, and some were vlookups from another page. The cells with vlookup formulas were not sorting properly either through a filter or through a sort. I copied the spreadsheet and pasted as values over the top of it and it sorted properly after that (although I lost they dynamic nature of the lookups.

share|improve this answer

This just happened to me - sometimes when you cut and paste information there are additional blank rows in the data and when you sort it will only sort to the blank rows. Go through and find the empty rows and delete them and then try and sort again.

share|improve this answer
    
I don't think that would make them ever appear on top (as stated in the question), but it might indeed apply to others who have a similar problem. –  Arjan Jul 14 '14 at 22:03

If you've reentered the data it is likely you've gotten rid of blanks. It is possible the rows are not included in the sort because they are not selected. If those 43 rows are not included in the sort grouping, they will not be sorted in the order you choose and will appear in their own group. Verify they are being included and retry the sort.

Also, make sure you don't have another conflicting sort or filter which is causing your issue.

You've not told us what type of data you are using. Mixed data can cause all kinds of issues with sorting. If it is mixed, it should be formatted as text. Here is more info about how to troubleshoot sorting.

share|improve this answer

I copied and pasted my data into a new sheet, without the headers. It sorted properly. Be sure to save your work prior to trying anything new!

share|improve this answer

This happened to me, I had to cut the rows that wouldn't sort and paste them into the data that WOULD sort. Then sorting them seemed to function.

share|improve this answer

You might have some of your rows in a table and some not. If you have banded rows, then those are probably in a table. Check the Design tab, Properties group, click Resize Table and make sure the range covers all of your rows.

share|improve this answer

My data had been copied to a new worksheet, and then at some point copied again. There were no visible filters and it sorted correctly until I added two rows of data. At that point, unless I sorted from elsewhere in the worksheet instead of from the headers, it missed two rows. I finally went to the Advanced filers dialog box and saw that a range had been entered at some point and it carried over, even though there was no remaining filter. Baffling. When I updated the range to include my two additional rows, it sorted correctly. I cannot clear the Advanced filter setting, so have learned to work with it as I add rows. I believe if I copied the data to another worksheet without the headers, I might solve the problem. An experiment for another time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.