Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got one of those LaCie iamakey flash drives and have been using it fine up until today when I plugged it into my work machine. The machine chugged away for a good while and finally mounted it to F:/

When I went into it; I found nothing that I had stored on there. In fact, in properties, the size shows as 0 bytes free out 0 which means my partition hadn't even been accessed by Windows.

I disabled our AntiVirus temporarily (Kaspersky) to make sure that the Device Protection was not the cause. As well, I tried manually uninstalling/reinstalling the drivers as well as checking Windows Update for newer ones. I've updated the keys firmware, and went in under our network administrator account to see if there was some weird driver permissions issue going on. Finally, I formatted the whole thing on a working computer and still got the issue.

None of those solutions have gotten me anywhere. And the most frustrating part is that every other computer I have used with this drive has worked. Of course; it's the exact computer I spend the most time on that it doesn't work on too.

I'm hoping the SuperUser hivemind can help me out on this one. If you need any more info just ask.

share|improve this question
I've seen the same symptoms on Windows 7 with a specific flash drive. Let's see if it's the same problem... open the Disk Management program, and while it's open, plug in your flash drive. It should work correctly. – Philip Nov 28 '12 at 20:34
Try deleting all partitions from the drive using GParted or Parted Magic or similar from Linux or a Linux LiveCD/USB, then recreating a single partition and formatting as NTFS. Then before you insert it in your problematic Windows machine, run USB Oblivion on the PC first. – Karan Nov 29 '12 at 17:25

I had this same issue with 2 laCies before and the fix was buying a new, non LaCie, drive... been golden ever since. I know this isn't a HELPFUL answer, but I'm just confirming the issue.

share|improve this answer
Hmm, not what I wanted to hear but it keeps me from pulling my hair out that's for sure. – CentiZen Nov 30 '12 at 19:11
Yeah. I was VERY disappointed with the drive. They did send me a replacement, but it ended up developing the same issue. oddly, on my mac, I was able to see the device plugged in, but couldn't see any storage from it. – Wescrock Nov 30 '12 at 21:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .