Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running an Asus router with DDWRT connected to a Comcast cable modem (a Motorola SB5101U). The router is set up to update a dynamic dns entry. It's doing this, and the IP is correct (i.e. nslookup gives the IP that my router thinks it has).

This IP is a 50.148.xxx.xxx IP, which is, to my knowledge, a public IP.

However, any attempt to ping this IP, or to send packets to any port on this router from external hosts (i.e. my shared web hosting box or school ssh server) end up in a blackhole.

While I'm on my home network, pinging my router's external IP does work.

Does anyone know what's going on?

share|improve this question
    
Is the router configured to reply to pings to its public address? If not, it won't. The router will do whatever you tell it to do. By default, it will ignore packets it wasn't expecting. –  David Schwartz Nov 29 '12 at 5:20
    
It is -- I can ping the external IP when I'm on my network. Also, if I try to connect to a forwarded port on the router, I have the same issue (packets disappear into the ether). –  Sam Mussmann Nov 29 '12 at 5:21
    
Sounds like you configured your router to block that sort of traffic ( pings ). –  Ramhound Nov 29 '12 at 5:25
    
I think this is a case of failure to read the configuration. I thought I was allowing pings, but inverted the meaning of the option, and then my port forwarding was to the wrong internal IP. So it doesn't look like I actually have a problem. I'll delete this question unless it's better that I leave it. –  Sam Mussmann Nov 29 '12 at 5:39
1  
Playing devil's advocate - if you are on a residential package you are not allowed (per the TOS) to run servers. Personally I think most TOS are just pieces of paper that you sign that attempt to scare you into being complacent. I haven't heard of anything getting cut off - but if you do call for support they do use that against you (personal experience). –  Nathan Adams Nov 29 '12 at 17:58
add comment

1 Answer 1

up vote 0 down vote accepted

I solved this myself. I had toggled the WAN ping option, which left the router not responding to pings, but me thinking that it did, and I had set up my port forwarding to forward to the wrong IP, so I thought it was broken, but it wasn't.

With those two options changed on my router, everything now works as I think it should.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.