Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The command I am using is:

wget -r -nH ftp://some.domain.com/home/work/test/* -P ./my

The output directory becomes:

./my/home/work/test/*

How can I make it to just ./my/*?

share|improve this question

migrated from stackoverflow.com Nov 29 '12 at 14:52

This question came from our site for professional and enthusiast programmers.

    
StackOverflow is for programming questions. – kazanaki Nov 29 '12 at 14:51
up vote 2 down vote accepted

Use --cut-dirs option. In Your case, --cut-dirs=3 to cut off home, work and test.

share|improve this answer

See the fine manual for a description of the --cut-dirs option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.