Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Windows 7 on the boot camp partition on my old Powermac G5 running 10.5.8.

I started by using the boot camp assistant (I think version 2.0) to repartition the drive. I then tried to use rEFIt to install Win7 on the boot camp partition from a USB drive, but that didn't work. So I booted back into OS X to finish the process with boot camp assistant and use a Win7 DVD to do the installation. Everything went smoothly and Win7 is up and running.

However, if I hold option to start and choose the Mac partition, nothing loads--it's just the Apple logo and a spinning wheel (waited 20 minutes at longest). Did I make a mistake not uninstalling rEFIt before installing win7 to bootcamp? I haven't installed the apple drivers in Win7 yet--does that have anything to do with it? I reset the nvram/pram, tried booting into safe mode by holding shift (didn't work), tried to get disk utility to show up with the command + R (nothing happened), and then tried a OS X disc 1 disc to boot from, but as soon as it booted, it told me I had to restart (same thing 3 times).

Please help!!

share|improve this question
1  
Did you try taking a backup of your Windows 7 Files and recover OS X via the Recovery Disk shown in the Boot Menu? –  AbhishekGirish Nov 29 '12 at 19:19
    
What recovery disk in the boot menu? there is none--and as I was informed Recovery didn't work because 10.5.8 doesn't have a recovery partition. –  rflusser Nov 29 '12 at 19:34
    
I use Mountain Lion (10.8.2) and it shows for me. I wasn't aware that it isn't part of 10.5.8. –  AbhishekGirish Nov 29 '12 at 19:43
    
SOLVED ITSELF. REBOOTED A FEW TIMES AND SOMEHOW JUST CAME UP. TOTALLY WEIRD. Was about to try another OS X disc and DiskWarrior as had been suggested to me. –  rflusser Nov 29 '12 at 21:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.