Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

DLink Router ------LAN Cable------>Linksys WRT54G (Set as AP).

From a machine connected wirelessly to DLink, I can't access Linksys AP (192.168.1.1). From another machine connected wirelessly to Linksys, I can access DLink (192.168.0.1) but not Linksys (192.168.1.1). Ping shows 100% packet loss.

Why am I not able to connect to the Linksys AP from any machine? (Both machines can access the internet). The machine connected to Linksys shows these entries:

IP Addr: 192.168.0.102

Gateway: 192.168.0.1

Subnet: 255.255.255.0

DNS: 10.6.6.16

share|improve this question
    
Did you connected the DLink router to the WAN/Internet port on the Linksys? (That would be incorrect, since they both are on the same LAN.) –  David Schwartz Nov 29 '12 at 20:54

1 Answer 1

up vote 2 down vote accepted

if you are in AP mode, both your router and your AP need to be in the same subnet (192.168.0.x). since one is on .1.1 and the other on .0.1 your WAP is either in router mode, or is incorrectly configured.

confirm the WAP is in AP/Bridge/Repeater mode, and then assign it the IP 192.168.0.2, or another unused address in .0.x. that should do you. Also, if your wireless device has a dedicated WAN port, don't use it, but instead connect the cable from your DLink into a LAN port on the WAP. In AP Mode, you don't use the WAN port.

since your WAP is in AP mode, it cannot route between networks, so traffic on the .1.x subnet would not be able to be routed to the .0.x subnet.

share|improve this answer
    
The connection to AP goes to LAN port. I think you're right about the AP not routing .1.x traffic to .0.x . I don't suppose these APs/routers be accessed by their WAN IP's...(which in AP's case is 192.168.0.103) –  koogee Nov 29 '12 at 22:11
    
If I'm understanding correctly, most routers won't let you connect to the management system over the WAN, since that would be a security risk. also when you are in AP mode, the WAN should be disabled. 192.168.0.103 should work fine. are you able to connect to it? does your ping work now? –  Frank Thomas Nov 30 '12 at 3:38
    
I reset the AP and changed its LAN IP to 192.168.0.3. Now its accessible on the network. Thanks. I'm accessing it right now from a machine connected to the dlink router. –  koogee Nov 30 '12 at 7:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.