Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I try to start Apache Maven at Win7 x64 SP1.

java version "1.7.0_09" Java(TM) SE Runtime Environment (build 1.7.0_09-b05) Java HotSpot(TM) 64-Bit Server VM (build 23.5-b02, mixed mode)

Apache Tomcat 6.0.36 x64 (also tried to use 7 version and x86 versions, no matter).

It falls immediately after start with an error:

java.util.logging.ErrorManager: 4
java.io.FileNotFoundException: C:\Programs\apache-tomcat-6.0.36" -Dcatalina.home=C:\Programs\apache-tomcat-6.0.36"\logs\catalina.2012-11-30.log

No log file created at \apache-tomcat-6.0.36\logs

I tried completely disable Windows firewall and UAC. It doesn't helps.

It seems like problem at the filename with quote:

C:\Programs\apache-tomcat-6.0.36"\logs\catalina.2012-11-30.log

Any suggestions how to solve this issue?

UPD: SET command results added

C:\Users\Dana>set
ALLUSERSPROFILE=C:\ProgramData
APPDATA=C:\Users\Dana\AppData\Roaming
CATALINA_HOME=C:\Programs\apache-tomcat-6.0.36\
CommonProgramFiles=C:\Program Files\Common Files
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
CommonProgramW6432=C:\Program Files\Common Files
COMPUTERNAME=DANA-PC
ComSpec=C:\Windows\system32\cmd.exe
FP_NO_HOST_CHECK=NO
HOMEDRIVE=C:
HOMEPATH=\Users\Dana
JAVA_HOME=C:\Programs\Java\jdk1.7.0
LOCALAPPDATA=C:\Users\Dana\AppData\Local
LOGONSERVER=\\DANA-PC
M3_HOME=C:\Programs\apache-maven-3\
NUMBER_OF_PROCESSORS=2
OS=Windows_NT
Path=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32
\WindowsPowerShell\v1.0\;C:\Programs\Java\jdk1.7.0\bin\;C:\Program Files\Microso
ft\Web Platform Installer\;C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET Web
Pages\v1.0\;C:\Program Files (x86)\Windows Kits\8.0\Windows Performance Toolkit\
;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Programs\apache-maven-
3\\bin\;
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
PROCESSOR_ARCHITECTURE=AMD64
PROCESSOR_IDENTIFIER=AMD64 Family 17 Model 3 Stepping 1, AuthenticAMD
PROCESSOR_LEVEL=17
PROCESSOR_REVISION=0301
ProgramData=C:\ProgramData
ProgramFiles=C:\Program Files
ProgramFiles(x86)=C:\Program Files (x86)
ProgramW6432=C:\Program Files
PROMPT=$P$G
PSModulePath=C:\Windows\system32\WindowsPowerShell\v1.0\Modules\
PUBLIC=C:\Users\Public
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\Windows
TEMP=C:\Users\Dana\AppData\Local\Temp
TMP=C:\Users\Dana\AppData\Local\Temp
USERDOMAIN=Dana-PC
USERNAME=Dana
USERPROFILE=C:\Users\Dana
VS110COMNTOOLS=C:\Programs\Microsoft Visual Studio 11.0\Common7\Tools\
windir=C:\Windows
windows_tracing_flags=3
windows_tracing_logfile=C:\BVTBin\Tests\installpackage\csilogfile.log
share|improve this question

1 Answer 1

Open the Environment Variables dialog (XP / Win7) and look for CATALINA_HOME under both the User and System variables sections. If it has a superfluous quote tacked on at the end, delete it, OK your way out and retry Tomcat.

share|improve this answer
    
I checked it already. There is no any quotes. –  Maxim Kolesnikov Nov 30 '12 at 1:29
    
Sure? Can you paste the result of set? Also, you didn't by any chance edit any of the batch files in Tomcat's bin directory, did you? –  Karan Nov 30 '12 at 1:42
    
OK, I added set results to my question. Moreover, if I remove CATALINA_HOME from Environment Variables nothing changes. And I didn't touch any batch files. It is fresh zip instance from official site. –  Maxim Kolesnikov Nov 30 '12 at 1:53
    
Can you remove the backslash at the end of CATALINA_HOME, and also fix the double backslash in the PATH to Maven's bin dir? –  Karan Nov 30 '12 at 1:57
    
OK, I did it and now Tomcat falls more quickly: no logs, no stacktrase. –  Maxim Kolesnikov Nov 30 '12 at 10:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.