Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using a netgear wireless router to connect to create a wireless network. When connected to the router via an Ethernet cable everything works correctly.

When connecting to the router via wireless only Google can be accessed. I've done searches via Google using random words to make sure that it is not a cached page, and these all work. However, trying to connect to any non Google domain the page fails to load.

I've accessed the connection with two different laptops, both are running Windows Vista. The network connection is strong on both, but the issue persists for both.

Edit: I have configured the wireless networks name and password, and connect to that using the credentials I have defined. I am sure I am not connecting to a neighbors wireless network.

Edit2: Typing in the direct IP address for ( ) would not resolve.

share|improve this question
What about the hints to try an IP address? – Arjan Oct 5 '09 at 20:38
I haven't gotten home from work yet to try the direct IP addresses – dmanxiii Oct 5 '09 at 21:45
...welcome back. What about CarlF's traceroute And as two laptops show the same problem, so it might be some router setting: I guess people may need to know the exact router type? And: any chance your internet provider limits its services based on some MAC address? I doubt the ethernet and wireless will expose different MAC addresses to your provider, but who knows... – Arjan Oct 13 '09 at 16:39

Do you have the Google Toolbar or something like that installed? What it sounds like to me is that there is no DNS server set up on your wireless DHCP, so you can't access any sites, but Google (for some reason) is either cached or in your local hosts or something, so it's getting out to that site.

Try connecting to some site via their IP address: If you can do that, then it's definitely DNS. (try: <--cnn com)

share|improve this answer

For Susan and anyone else who's having the same problem and stumbled onto this page. I had the same problem with a Belkin router. Connecting to it via cable worked fine but the wireless connection only let me access Google affiliated sites. In my case, I was able to solve it by disabling "WMM mode". Then I could connect to the Internet just fine. I still have no idea what WMM mode does or doesn't do but disabling it was the only thing that worked. Switching wireless channels, changing wireless modes, none of these worked.

share|improve this answer

Why would you need to connect anywhere else? ;)

Seriously, have you run a trace with Wireshark? Have you tried pinging the sites from the command line to see if it's name resolution or the actual connection?

Do you have any special settings in the router for the WLAN?

share|improve this answer

Try connecting to (Superuser's IP address). If that works, you know the problem is DNS. If not, not.

If it's not DNS, try a traceroute to that IP address. Where does it fail?

I agree with Anakun that you may not be connecting to your own router.

share|improve this answer

My fix was to open the network properties, select ipv4 properties and have obtain an IP address automatically selected. After doing all the other recommendations and manually entering a DNS address ( did this work- such a simple button!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .