Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know it is a common problem and there are many solutions on the web but I'm trying everything and anything is working, I can't have phpmyadmin running on my machine. I installed XAMPP through:

sudo tar xvfz ./Downloads/xampp-linux-1.8.1.tar.gz -C /opt

then I did the chmod trick supposed to make an end to access issues and I change the default location to my php projects from /var/www to Dropbox/php.

Then I started XAMPP in the usual way:

sudo /opt/lampp/lampp start

When I tried to run one of my php projects the output on the web is fine but if for example I try to write localhost on my browser I get:

It works

and not the usual XAMPP interface and most of all when I try to access localhost/phpmyadmin I get the login page, insert username (root) and password and I get:

You don't have permission to access /phpmyadmin/index.php on this server.
Apache/2.2.22 (Ubuntu) Server at localhost Port 80

I tried the Required all granted trick and some others but nothing is working. I even tried to uninstall phpmyadmin and reinstall it but this is not working too. I don't know hot to proceed.

Thanks for your help.

share|improve this question

You dont show any config, logs, so lets give generic tips:

First try to stop the lampp and check if you can still connect to the webserver. This will test if you have another webserver running or are connecting to another machine server (via a bad localhost dns or hosts entry, or via a proxy)

If it fails, try to go to the /opt/lampp/bin and do

./apachectl -S

and see what it says. It should list the virtualhosts and the first should be the default site. Check if the localhost name (or the default if it doesnt exists) is mapped to the right config and if in that config file, on the line number (the number after the : on the file name) have the right config namely the DocumentRoot and the correct entry giving access permissions to that documentRoot.

Also check if there is alias for the phpmyadmin and that destination also have a entry

finally, check the logs: /opt/lampp/logs/error_log and read what it says

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.