Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So yesterday, I forcibly restarted my Windows 8 PC. VMWare Workstation was having some trouble with the guest Linux Mint OS. It wasn't responding for some time, so I tried suspending it September 28th or perhaps even before. It wouldn't suspend -- I forgot what the window looked like, but all options in the power menu were disabled (i.e. "Shutdown," "Power Off," and options like that were all disabled). I eventually killed the VMWare application through Task Manager, though I was too lazy to hunt down the running virtual machine itself, and decided to kill it by just shutting down my PC entirely.

The PC wouldn't shut down for quite some time after the monitor went blank, so I did a cold reset by holding the power button. I then powered it on again and Windows briefly gave me some message like "Search for KERNEL_STACK_INPAGE_ERROR." Windows then started diagnosing some problems and gave me the message, "Repairing disk errors. This might take over an hour to complete." That was yesterday night, and I went to sleep without waiting for it to finish.

This morning, it said that the repair failed, and that the log was at C:\windows\system32\LogFiles\srt\srtTrail.txt (as I remember it -- I don't have the exact path I wrote down right now). It gave me some other options to troubleshoot, such as resetting Windows (files and settings still intact, but programs not installed through the app store will be erased). That didn't work (no error message given, I was just told it didn't work). I tried rebooting in safe mode, the same diagnosis process begins, except that this time it doesn't bother with the automatic repairs again.

So I tried using the command prompt to try to see if my files are at least still there. I was on the X drive, and I couldn't cd to the C drive. I couldn't find my folder under Users (of course?), and couldn't find the srt folder under LogFiles either.

I am not sure what to try next. I have backed up everything, but to the cloud, so if absolutely necessary I can start off with a fresh copy of Windows and restore all my data, though it would be a hassle. Any thoughts on what might be wrong or what I can try? My computer was purchased just this June, so the hard drive should still be pretty new.

EDIT: I just went home and discovered that the location of the file was actually in drive D for whatever reason... I found it, and here are the contents:

Startup Repair diagnosis and repair log
---------------------------
Number of repair attempts: 1

Session details
---------------------------
System Disk = \Device\Harddisk0
Windows direcory = D:\Windows
AutoChk Run = 0
NUmber of root causes = 1

Test Performed:
---------------------------
Name: Check for updates
Result: Completed successfully. Error code = 0x0
Time taken = 0 ms

... some other tests are performed and completed successfully,
such as system disk test, disk failure diagnosis, disk metadata test,
target OS test, volume content check, boot manager diagnosis,
and system boot log diagnosis...

Root cause found:
---------------------------
Boot manager failed to find OS loader.

Repair action: File repair
Result: Failed. Error code = 0x2
Time taken = 3188 ms

Repair action: Boot configuration data store repair
Result: Failed. Error code = 0x2
Time taken = 0 ms

So now I suppose I will boot from my Windows 8 install CD and see what that can do... except that my disk drives do not have a physical button to eject discs, so I will need to eject it from within the limited Windows 8 interface...

EDIT 2: Upon further internet searches, it turns out that there is a physical button to the side of the CD drive that I had never before noticed. Nevermind...

EDIT 3: Apparently my bootloader is corrupt. I also tried running the commands bootrec /fixmbr and bootrec /fixboot when booting from the Windows 8 CD. No luck still, despite the commands having completed successfully. I guess the question may be, how do you restore the Windows 8 bootloader?

EDIT 4:

So as one of the answers said, I did

>bootsect /nt60 ALL /MBR
Target volumes will be updates with BOOTMGR compatible bootcode.

C: <\\Volume{6c04.... long string of alphanumeric chars and dashes}>

    Successfully updated NTFS filesystem bootcode.

D: <\\Volume{6c04.... long string of alphanumeric chars and dashes}>

    Successfully updated NTFS filesystem bootcode.

E: <\\Volume{6c04.... long string of alphanumeric chars and dashes}>

    Could not open the volume root directory:
        The parameter is incorrect.
...
H: (same as E)

\??\PhysicalDrive0

    Successfully updated disk bootcode.

\??\PhysicalDrive1

Could not prepare disk(s) for update:
    The device is not ready.

...

\??\PhysicalDrive4 (same as physical drive 1)

Bootcode was successfully updated on at least one volume.

Now I find that there is no "Windows" folder in the C drive, but only in the D drive. So I do this:

>bcdboot D:\Windows
Boot files successfully created.

I restart, and am presented with a different message:

Recovery

Your PC needs to be repaired

The application or operating system couldn't be loaded because a required file is missing or contains errors.

File: \Windows\system32\winload.exe
Error code: 0xc000000f

You'll need to use the recovery tools on your installation media. If you don't have any installation media (like a disc or USB device), contact your system administrator or PC manufacturer.

Press Enter to try again
Press F8 for Startup Settings

Progress! (I think)

EDIT 5:

I give up. A bunch of critical Windows system files seem to be missing. Only about 30 GB of space seem to be used on D:\, whereas I am absolutely positive I had used > 100 GB on my hard drive, so I have already lost massive amounts of data. I am going to just reinstall a fresh copy of Windows, and download all my backed up data again...

Many thanks to everyone who helped with this problem!

share|improve this question
    
If the repair console failed then you are likely out of luck. Unless you post the log file we can't really help. –  Ramhound Nov 30 '12 at 17:22
    
Are you booting from external media - USB/DVD ? Can you still boot from hard disk ? Do you get the options to Recover your system using Refresh/Reset ? –  snayob Nov 30 '12 at 19:58
    
@Ramhound I can't access that log file -- I can't cd into the C drive, and the srt folder is nonexistent on the X drive... :( –  wrongusername Nov 30 '12 at 23:16
    
@snayob I'm booting from the internal hard drive, which is what fails and gives me that error screen. I did get to that Refresh/Reset screen, but the refresh failed, and I don't want to try the Reset yet if there is still a way to keep my data intact. I will try booting from external media next. –  wrongusername Nov 30 '12 at 23:25
1  
@wrongusername ww2.justanswer.com/uploads/Claws224/… –  Lee Taylor Dec 1 '12 at 12:40

1 Answer 1

There are two commands for fixing the boot environment.

Boot installation/recovery media (DVD/USB/CD) and go to command prompt.

1. bootsect /nt60 ALL /mbr

  • This fixes boot sectors and MBR.

2. bcdboot d:\windows - (in your case) check again if d: contains \windows folder, if necessary change drive letter.

  • This fixes boot manager and BCD.

FYI - Boot files are written always to active partition on MBR disk ( EFI system partition on GPT disk ).

share|improve this answer
    
I've tried both and got a new error message! –  wrongusername Dec 2 '12 at 0:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.