Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Windows 7 before it even gets to login. On the "starting windows" splash screen takes no less than 15 minutes to finish more like 25 minutes most times. During this time the hard drive activity led indicator is blinking maybe once every 20 seconds.

When I finally get to the desktop everything runs normally. I have unplugged all peripherals with same result.


It's 32bit. 4gig memory. Fast CPU which I can't recall off the top of my head.

share|improve this question
This sounds like your HDD is about to fail, or at the very least, its fragmented to heck. Exact specifications are also required. – Ramhound Nov 30 '12 at 17:51
Are you on a company domain network? – Ƭᴇcʜιᴇ007 Nov 30 '12 at 18:01

run a disk check (Rclick a drive -> Properties-> Tools -> Check disk for Errors) and also do a RAM check

if the disk has issues, the chkdsk should fix it if it is possible, and if the ram is faulty or incompatible, replace it.

Check the SMART stats for your disk, is it healthy? I use Speedfan to check SMART metrics.

Defragment your hard disk.

also look in Device manager. do you have any devices with a warning exclamation point icon? if so, are they integrated components or peripherals? attempt a troubleshooting operation to try to fix it.

use sysinternals autoruns to check for and disable unneeded startup items that may be causing problems.

check your CPU heatsink fan, and make sure it is powering up and spinning fast. if it has died your CPU may be seriously overheating. Bootup is a very hot time for a CPU, because the ACPI has not loaded all the power management drivers yet and cannot automatically adjust as well as after boot.

check your event log for large numbers of errors related to a boot.

make sure your disks are in AHCI mode (don't change it from IDE without an internet search first as you may have to adjust things to allow AHCI to boot if windows was set up in IDE mode).

if all else fails, try a rebuild. if the issue persists on a clean build, then you have a hardware problem.

share|improve this answer
Appreciate the assist. Will try all of these when it finally boots. I just tried and it was going on 45 minutes. I'm mobile right now. :( – Tyler Nov 30 '12 at 17:49
Oh, one other thing to try: once booted, shut down all applications, and enter 'sfc.exe /SCANNOW' in a command prompt. it will take a while, but it checks all your windows registered system files and attempts to repair them from WFP backups if possible. – Frank Thomas Nov 30 '12 at 21:32

I'd install a fresh Win7 on a SSD drive. It's super fast for my setup with Core i7 running. However, when I did install a SATA peripheral it slowed the startup way down... FYI.

Then hook that old HD up and pull all the data onto a new drive. It could just need a reformat...

share|improve this answer

I've seen this on PCs joined to a Windows domain when connected to networks where the PC thought that domain should be available, even though it's not, or where the domain is available but some issue is preventing good communication. The PC can spend ages trying to connect to the domain and apply group policy settings that will never come.

share|improve this answer

The best way to determine if it is your hardware or your windows installation is to boot from something else. Download a liveCD (it does not matter which one), but that and try to use the computer for a while.

If it is as slow then you have a hardware problem. The next step would be to determine which hardware part is broken.

If it is not slow then you either have a problem in software, or with the hard disk (which is not used when booting from a liveCD/live pen drive. Mount the drive and try to use it (e.g. copy everything off the HDD to another location).

If it fails at that point you likely have a drive with problems.

share|improve this answer

I've seen this on a machine where I'd plugged in a USB key drive weeks earlier and forgotten about it. The machine was a Dell with a front flap that hid the key drive. I know you say you've unplugged all peripherals, but it sounded similar enough I thought I'd mention it.

share|improve this answer

Run xbootmgr to see what happens:

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .