Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Windows 7 Home Premium and external USB disk with NTFS partition.

I cannot write-access the my own files on it, even as a member of Admnistrators group!

Is there any way how to go around this permission checking, without actually writing some permission information to every folder on it? I have 3 external disks (up to 1TB), and I have thousands hundreds of files on each!!! Doing some permission change, that will actually go recursivelly through all folders on all my disks is plain brain damage!!

1) Is there any way how to change it somehow globally? (like mount options...)

.. Or how to go around this annoying permission checking? It was working in Win XP normally!

2) if not, and I must do the recursive operation on all folders, how to do it PERMANENTLY, so that I don't need to do it again on another Windows 7 computer!

share|improve this question

2 Answers 2

I'm afraid the issue is ownership info on the file and folder objects, so a recursive operation is required, but it runs really fast. the number of files is primary factor for time; size is irrelevant.

if you RClick the drive -> Properties -> security -> advanced -> owner -> Edit -> Select the administrators group, check the box to indicate a recursive change, and apply. should only take a few minutes. Note: use the administrators group, not your user. the issue here is that the owner user account/SID for the files does not exist on your machine. the Administrators group uses a well known SID which does not change from system to system, so you should not have to do this again even if you take the drive to another machine.

unfortunately Windows doesn't use mount options for security, instead storing each permission in the file metadata. just as you have proven with your issue, that keeps the privileges in place even when the drive is removed and put somewhere else, which mount options could not do.

share|improve this answer
1  
thanks for answer! However, the group "Administrators" already owns the folder(s)! And I am member of this group (cmd: net localgroup Administrators)And please have a look at point 2) in my question (I've just added it), thanks!! –  Tomas Nov 30 '12 at 21:16
    
weird. the SID of the administrators group should be universal across all windows boxes, so by using it, it should allow you to move the disk from station to station without issue. –  Frank Thomas Nov 30 '12 at 22:07
up vote 0 down vote accepted

Disabling UAC and restarting finally did it, without any change on the hard drives! See How to set permissions on external hard drive in Windows 7

But, disabling UAC is a security risk... I would like to disable it only for those hard drives...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.