Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have apache installed manually from the source code, but I require now to install it using apt-get, because it seems this will make stuff easier to install mod_wsgi from apt-get also (it will see that apache2 is installed, I guess)

so now when I run sudo apt-get install apache2 I got the following error:

The following packages have unmet dependencies:
  apache2: Depends: apache2-mpm-worker (= 2.2.14-5ubuntu8.10) but it is not going to be installed or
                    apache2-mpm-prefork (= 2.2.14-5ubuntu8.10) but it is not going to be installed or
                    apache2-mpm-event (= 2.2.14-5ubuntu8.10) but it is not going to be installed or
                    apache2-mpm-itk (= 2.2.14-5ubuntu8.10) but it is not going to be installed
           Depends: apache2.2-common (= 2.2.14-5ubuntu8.10) but it is not going to be installed
E: Broken packages

and even when trying to install apache2.2.-bin (as 2.2-common depends on it), the following error is raised:

The following packages have unmet dependencies:
  apache2.2-bin: Depends: libaprutil1-dbd-sqlite3 but it is not going to be installed or
                          libaprutil1-dbd-mysql but it is not going to be installed or
                          libaprutil1-dbd-odbc but it is not going to be installed or
                          libaprutil1-dbd-pgsql but it is not going to be installed or
                          libaprutil1-dbd-freetds but it is not going to be installed
                 Depends: libaprutil1-ldap but it is not going to be installed
E: Broken packages

Skimming around I understood that it says that it doesn't know which one of the dependencies to install (seems all work).

and this last error when running for example: sudo apt-get install libaprutil1-dbd-sqlite3

The following packages have unmet dependencies:
  libaprutil1-dbd-sqlite3: Depends: libaprutil1 (= 1.3.9+dfsg-3ubuntu0.10.04.1) but 1.3.9+dfsg-5 is to be installed
E: Broken packages

Any help ??

share|improve this question

migrated from stackoverflow.com Dec 1 '12 at 7:14

This question came from our site for professional and enthusiast programmers.

You don't install just 'apache2' as that is the generic component. You need to install a specific MPM, such as 'apache2-mpm-worker'. Did you try that?

share|improve this answer
    
yes, and it doesn't work also as it depends on apache2.2-bin, and it has the error shown above :( – Loai Ghoraba Dec 1 '12 at 4:49
    
This should not be that hard. Looks like something has been screwed up in your system. – Graham Dumpleton Dec 1 '12 at 4:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.