Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since 2 or 3 days, when I click a download link on the web, the Save As dialog box appears too late. It seems that the computer first downloads the full file to the PC, and only then shows me the Save As dialog box.

Same situation in YouTube, Dailymotion or any other video web site. First, it waits for the full video to be loaded and only then starts to play the video.

The problem occurs with both IE8 and Firefox 3.5.3. I am using Kaspersky Internet Security 9. But it's the same since my OS set-up. I am also using Microsoft Security Essentials.

UPDATE: I uninstalled MS Security Essentials and changed the setting of Windows "Background Intelligence Transfer Service" from "manual" to "automatic". Now everything seems OK. But I am not sure if the problem disappeared because of which change.

share|improve this question
    
Have you installed any applications, or changed any notable configuration in the past few days? You say it happens in both IE and FF, so it seems unlikely that it's a FF add-on (although not impossible, I suppose). –  JMD Oct 5 '09 at 18:16
    
I don't remember any important changes on my software cay be I changed a setting of a windows service from auto start to manual start.But I don't remember.I have a 1mbps internet connection. –  NT. Oct 5 '09 at 18:23
    
Is it the case for all downloads or only for some file types (try to d/l a large product from download.com)? Is it the same for FF in safe mode? Does complete uninstall/reinstall of FF with delete of the install dir change something (for FF, at least)? –  harrymc Oct 5 '09 at 19:11
    
It's same for all download with both FF and IE8.So I don't think that uninstalling FF will help :( –  NT. Oct 5 '09 at 19:22
    
When did you start using Microsoft Security Essentials? And as I don't know if Firefox uses the Windows Background Intelligence Transfer Service: do you use any download manager (like some Firefox add-on)? –  Arjan Oct 8 '09 at 8:25

3 Answers 3

Sounds a bit like security software not showing you anything until it's checked the whole thing itself. What firewall/AV are you using?

share|improve this answer
    
I am using Kaspersky Internet Security 9.But it's the same since my OS set-up. –  NT. Oct 5 '09 at 19:56
    
But also Microsoft Security Essentials. Maybe having the two running simultaneously caused the problems. (If so, then we'll soon be seeing more people with that problem soon on Super User...?) –  Arjan Oct 8 '09 at 8:22

It seems unlikely that it's firefox's fault, but it's not impossible (even if it's also happening to ie8). I really recommend backing up, uninstalling, removing your personal firefox folders (C:\Users\USERNAME\AppData\ if you're in vista or 7), and then installing again. You can backup just about everything in firefox with the FEBE extension, making this whole process pretty painless. If it solves the problem, restore your extensions and plugins one by one to find out which one caused everything.

As mentioned by CodeByMoonlight, your antivirus might be the cause of this (it might have updated recently, and changed it's standard behaviour) you could try disabling it momentarily just to test the possibility (even unlikely).

Finally we could also try to blame ie8, a newly installed software, or a recent windows update (I've seen windows updates cause an issue or two). In that case, performing a System Restore should fix it immediately, it's also painless and takes only a few minutes. You'll only have to reinstall anything you installed since the point you restore from.

Let us know if you try anything.

share|improve this answer
2  
Yesterday I uninstalled MS Security Essentials and changed the setting of "Background Intelligence Transfer Service" from "manual" to "automatic".Now everything seems OK.But I am not sure if the problem disappeared because of which change. –  NT. Oct 6 '09 at 16:49
    
I'd bet on MS security essentials, though not more than a penny =) If you're interested, just switch BITS back to manual and see if it happens again. –  Malabarba Oct 8 '09 at 0:19

You might also try right-clicking the link (to a video for example), and the selecting "Save link as..." (or similar).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.