Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I try to update my iTunes to version 11 but every time I open iTunes after the restart it shows me an error message that states, "An Unknown Error Occurred (-42408)".

The same thing happens when I try to install it using the stand alone installer from the apple website.

iTunes still opens but remains as version 10.7 (21) and dosent update. I have tried this numerous times and I keep getting the same results.

I have also looked all over online but none of them give me a solution that works.

My system is a MacBook Pro (15-inch, Mid 2012), OS X Mountain Lion (10.8.2)


share|improve this question

Sounds like your library file might be corrupted, or there are other permissions issues on your drive.

Two things to try:

1) Hold the Option/Alt key while launching iTunes and attempt to create a new library. If iTunes launches without error with a new library, then you know the problem is with your old library. If the problem persists, your library is most likely OK.

2) Open Disk Utility (/Applications/Utilities/Disk, or just type Disk Utility into Spotlight), select Macintosh HD, and click "Verify Disk Permissions" and then "Verify Disk". If either of those come back with errors, use the provided Repair buttons to attempt to fix them, then try again.

If you're library is bad, it's not a big deal, its just the metadata that has issues, the actual files are probably fine. You'll lose your play counts, playlists, and dates (added, played, etc), but you can import the music into the new library and be fine.

share|improve this answer
Thank you for your help, but none of your suggestions have worked. Creating a new library still brings the error up and repairing permissions only found a few problems in the Printer directory. – joshkrz Dec 2 '12 at 20:30
up vote 0 down vote accepted

OK, I managed to figure this issue out.

I have a folder in Applications where I put all the Apps I use. The ones I can't move I make an alias to.

The iTunes 10 App was in this folder and pinned to my dock, so when I was actually opening iTunes 10 alongside iTunes 11 being installed.

I stumbled across the iTunes 11 icon in the Applications folder, whilst trying to reinstall iTunes 10.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.