Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can setup my normal GTalk account in Pidgin, but I don't know how to do it with my work GTalk which is for a Google Apps domain.

share|improve this question

5 Answers 5

up vote 32 down vote accepted

  1. You have to change the advanced options of the account.
  2. Check box for "Force old SSL..."
  3. Set "Port" to 443 (if 443 doesn't work, try 5223)
  4. Set "Server" to

share|improve this answer
Haha, asked the question, then used the web site to find the answer? ;) –  JMD Oct 5 '09 at 18:35
@JMD exactly, it's my contribution for the community –  Jader Dias Oct 5 '09 at 19:29
Why third party blog links ? Google's Support page mentions it. –  Sathya Oct 5 '09 at 20:19
Sathya: This answer was the only one that enabled my Work GTalk on Pidgin after searching wildly on the internet. The key was to use 'Use old style SSL' and to set the port to '443'. This isn't mentioned in Google's support page. –  runaros Mar 20 '12 at 15:05
@runaros what version of pidgin? –  Evan Carroll Feb 26 '13 at 22:09

From the Official Article: Configure Pidgin to connect to Google Talk (with modifications by me):

Once you download Pidgin, you'll need to configure your client to connect to the Google Talk service.

To configure your account:

  1. Open Pidgin.
  2. Select Add (under Accounts → Manage Accounts → Add)

Enter the following information in the Add Account window:

Protocol: XMPP

Screen Name: your Google Talk username without any @ symbol or domain *content to the left of the '@' symbol).

Server: (or Domain) Enter the portion of your email address after the @ symbol. For example, will enter as the server value. (If you're not a Google Apps for Your Domain user, please visit the Google Talk Help Center for instructions.) Password: we suggest leaving this field blank for increased security, but if you'd like to log in automatically, enter your password

Local Alias: leave this field blank

Remember password: check the box if you'd like Pidgin to remember your password (you won't be prompted to enter it each time you log in, if you select this option)

New mail notifications: check the box if you'd like Pidgin to notify you of unread email in your inbox.


  1. Click the 'Advanced' tab and select Require SSL/TLS, or sometimes more simply Require Encryption.
  2. Google doesn't say this, but make sure under "Connect Server:" that is set.
  3. Click Save.

You're now ready to connect to the Google Talk service using Pidgin.

share|improve this answer

An updated answer: Let's say user is
Setup a Gtalk account with the following details:
User: myname
Password: **** (enter your password here)

Then click on advanced and the only change to the defaults is the connect server:

Connect Server:

You should be set now.

I tried this and it worked for me.!topic/apps/RWb8R-vg_qM has more details.

share|improve this answer

You also have to have your /etc/hostname in your /etc/hosts.

I mean : if /etc/hostname contains julien you need a localhost julien in your /etc/hosts.

share|improve this answer
How on earth is this related? :P –  Metagrapher Sep 4 '13 at 15:28
Don't remember exactly, but my pidgin won't connect to gtalk without this. I may try removing it to check why. –  Julien Palard Sep 7 '13 at 12:58

This has changed. We need to set app-specific password. Just follow instructions at

share|improve this answer
Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. –  DavidPostill Sep 26 at 11:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.