Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I turn off all tooltips in xfce (version 4.10)?

Or (if this is easier): How can I turn off the tooltip for a launcher icon?

share|improve this question

migrated from stackoverflow.com Dec 1 '12 at 15:33

This question came from our site for professional and enthusiast programmers.

1  
This kind of question is more suitable for SuperUser; SO is for programming questions, not WM config questions. You'll get much more help on SU, hence the move vote. Don't be dissuaded :). – Bojangles Dec 1 '12 at 9:41

Done, I have updated to make complete answers below.

How can I turn off all tooltips in xfce (version 4.10)?

According to this forum thread, all tooltips on Xfce could be disabled by following steps below.

For system wide

  • Create .gtkrc-2.0 file in your Home directory (if the file doesn't exist)
  • Open the file in a Text editor, and type gtk-enable-tooltips = 0
  • Save and close the file
  • Log out from current session, then log in again

After you log in, the tooltips will no longer appear anywhere on the system.

I have tested this on both Xfce 4.8 and 4.10, and it works as reported on Xubuntu. However, some users reported that this doesn't work well with Xfce on Debian.

That's it.

Or (if this is easier): How can I turn off the tooltip for a launcher icon?

On Xfce 4.10, you can achieve these easily.

For launcher icon on Desktop

  • Go to Settings > Desktop
  • Click on Icons tab
  • Under Appearance, look for Show icon tooltips and deselect/leave uncheck

For launcher icon on Panel

  • Go to Settings > Panel. Click on Items tab.
  • From the item listing, make selection on Launcher.
  • Then look for gear icon on the right and click on it to run Launcher setting dialog.
  • Click on Advanced tab, then look for Disable tooltips and deselect/leave uncheck

For launchers in Application Menu (Panel item)

  • Go to Settings > Panel. Click on Items tab.
  • From the item listing, make selection on Application Menu.
  • Then look for gear icon on the right and click on it to run Applications Menu setting dialog.
  • Under Appearance, look for Show applications descriptions in tooltip and deselect/leave uncheck

Some Xfce components doesn't have tooltip option, such as for Window Buttons (tooltip cannot be disabled) and Whisker Menu (there isn't any tooltip for launchers, only application description).

But at least you can disable the tooltip for items above (via GUI).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.