Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently set up my work and home computers to be able to remote to each other so I can work from home and so I have a computer outside our network to run tests using a separate ISP for certain problems that come up every once in a while.

I can remote from my machine at home (HM1) to my work machine (WM1), but I cannot connect to my HM1 from WM1. I can successfully ping HM1 from WM1. When I click "Connect" on the Remote Desktop Control window at work, it immediately comes up with the "This computer cannot connect to the remote computer" error.

As a test, I tried to connect to a coworkers home machine (HM2) from WM1 with the same result (he can successfully remote into his home machine from his work machine). I can, however, remote into any machine on our work network successfully.

Additionally, I was able to successfully remote into HM1 from my coworker's work machine (WM2). Once I had access to my computer, I was then able to remote into my work computer (WM1).

We've both checked and double checked both firewalls involved and all router and computer settings and cannot see why it is working on one machine but not the other. At this point, we feel it has to be something on WM1 that is causing this error.

Has anyone run into this or does anyone have any suggestions as to what on WM1 might be causing this?

HM1 is running Windows 7 Professional 64-bit while WM1, WM2 and HM2 are running Windows 7 Professional 32-bit.

share|improve this question

1 Answer 1

I found (quite by accident) the solution. We use a Lightspeed web filter here at work and my coworker had set up an exception for his computer. Once I added an exception for my computer, I was able to successfully remote into my home computer. We didn't check the filter before as we didn't think it had anything to do with RDP, but apparently it does. Just FYI if anyone ever faces a similar problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.