Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 8 (no virtualization, X79 + i7-3820), and have separate Linux NTP server in my local network. Linux NTP is typically within 1ms of true time.

I've set Windows 8 to synchronize time via my local NTP, and set

SpecialPollInterval = 1 MinPollInterval = 6 UpdateInterval = 100

When network is available, all is fine, Windows 8 have clock offset less than 1ms.

But when there is no connectivity, clock drifts very fast, 90ms per 1 hour, and I see that w32time service does not try to compensate for it (like Linux NTP does).

What should be done to have w32time compensate for constant clock drift?

share|improve this question
    
I'm getting bad drift only in Windows 8 and it doesn't matter that the network is available and that the Windows Time service is running. –  uosɐſ Dec 3 '12 at 3:28

1 Answer 1

Have you tried installing linux or 7 there and seen if the behaviour is better, to rule out any hardware issues?

I found this link in another question that outlines some recommended settings for a domain controller for both hardware based sync or external sync. Perhaps you could also try those. Also I wouldn't be terribly surprised if setting the sync interval to very low (every second with correction every 100 ticks like your example) could screw things up if that wasn't tested at MS.

http://support.microsoft.com/kb/816042

Here are Windows 7 default settings from fresh and updated install.

C:\Windows\system32>w32tm.exe /query /configuration

[Configuration]

EventLogFlags: 2 (Local)
AnnounceFlags: 10 (Local)
TimeJumpAuditOffset: 28800 (Local)
MinPollInterval: 10 (Local)
MaxPollInterval: 15 (Local)
MaxNegPhaseCorrection: 54000 (Local)
MaxPosPhaseCorrection: 54000 (Local)
MaxAllowedPhaseOffset: 1 (Local)

FrequencyCorrectRate: 4 (Local)
PollAdjustFactor: 5 (Local)
LargePhaseOffset: 50000000 (Local)
SpikeWatchPeriod: 900 (Local)
LocalClockDispersion: 10 (Local)
HoldPeriod: 5 (Local)
PhaseCorrectRate: 1 (Local)
UpdateInterval: 360000 (Local)


[TimeProviders]

NtpClient (Local)
DllName: :\Windows\system32\w32time.dll (Local)
Enabled: 1 (Local)
InputProvider: 1 (Local)
AllowNonstandardModeCombinations: 1 (Local)
ResolvePeerBackoffMinutes: 15 (Local)
ResolvePeerBackoffMaxTimes: 7 (Local)
CompatibilityFlags: 2147483648 (Local)
EventLogFlags: 1 (Local)
LargeSampleSkew: 3 (Local)
SpecialPollInterval: 604800 (Local)
Type: NTP (Local)
NtpServer: time.windows.com,0x9 (Local)

VMICTimeProvider (Local)
DllName: C:\Windows\System32\vmictimeprovider.dll (Local)
Enabled: 1 (Local)
InputProvider: 1 (Local)
NtpServer (Local)
DllName: C:\Windows\system32\w32time.dll (Local)
Enabled: 0 (Local)
InputProvider: 0 (Local)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.