Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently ripped my HDD out of my mid-2010 Macbook Pro to replace with a 128GB M4 SSD drive. I upgraded to Mountain Lion and performed a software update. I want to install Windows 7 Professional with SP1 (I have an .ISO of the DVD.) I also bought a hard drive caddy to replace the optical drive with the old HDD.

I began by following the directions at thenextweb for installing Win7 to Boot Camp without a DVD drive.

I am getting around the Boot Camp requirement of having an optical drive by using Daemon Tools Lite for mac to mount the .ISO to convince Boot Camp to partition the drive and reboot the machine (rather than Roxio Toast, as indicated in the guide, as that product costs money and is difficult to track down.)

I have also burned the .ISO to a flash drive using the Windows 7 USB/DVD Download Tool as suggested in the guide, although on restart I'm not sure whether that flash drive is being booted into or whether OS X is mounting the .ISO and using it.

I downloaded the Windows 7 Support Software to a separate external flash drive during the Boot Camp Assistant wizard, and managed to have the computer reboot and the Windows 7 installation begin.

However, I am getting the following error when selection the "Disk 0 Partition 4: BOOT CAMP" 50GB partition that I had Boot Camp Assistant create:

Windows cannot be installed to this hard disk space. Windows must be installed to a partition formatted as NTFS.

Windows cannot be installed to this hard disk space. This partition is of an unrecognized type.

Disk utilities are available, and I am able to delete and create a new partition, but when I attempt to format it, I get the error "Failed to format the selected partition. [Error 0x80070057]."

I have also tried following the directions for Installing Windows on a Macbook Pro without a Superdrive which cleverly suggests starting the installation using VMWare Fusion and following the install process up until the first restart, and then rebooting into the drive. That worked a charm but the process continues to stall out when attempting to install to that partition.

share|improve this question
    
Searching more widely, it appears to me that I need to install some drivers for the nVidia MCP79 AHCI chipset that I have (I used the "System Information" app in OS X to see under Serial-ATA.) It was extremely difficult to find drivers labeled for that, but I looked through the Windows Support drivers that Boot Camp installs, under Intel, and found many "Intel ... AHCI" drivers. In desperation, I tried one, and was then able to format the drive with the Windows Installer and continue the install! Will report back on whether the entire process is successful with this method –  urbushey Dec 1 '12 at 21:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.