Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use ubuntu 12.04 on a beagleboard-XM. I use wireless dongle on the board for wireless interface

root@ubuntu:/# uname -a
Linux ubuntu 3.2.0-23-omap #36-Ubuntu Tue Apr 10 20:24:21 UTC 2012 armv7l armv7l armv7l GNU/Linux

I use wireless dongle on the board for wireless interface. The name of the wireless interface changes time to time, e.g., it is wlan0, after some reboot procedure wlan3 is assigned for the interface,then wlan2, etc. Btw, the USB dongle is always connected to the same USB port.

Is there any way to have a static wireless interface name, e.g. wlan0? Because I assign static IP on /etc/network/interfaces for the wireless interface, the board cannot get the predefined IP when the wireless interface is named differently.

I would appreciate for the suggestion to fix the name of the wireless interface.

share|improve this question

migrated from stackoverflow.com Dec 1 '12 at 23:58

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer

up vote 0 down vote accepted

You can use tool called ifrename. Install it:

sudo apt-get install ifrename

Check the MAC address of the card from HWaddr parameter of ifconfig output:

sudo ifconfig <device-name> |grep HWaddr

Then write the file /etc/iftab:

<device-name-you-want> mac <mac-address-of-the-device>

e.g.

eth0 mac 00:17:31:56:BC:2D

Reboot and you should be done. The renaming is done by start-up script /etc/init.d/ifrename.

More information can be found from Debian Administration site and alternative methods for example from AIR Wiki.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.