Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I installed Windows 8 on a machine that already had Windows 7. They are on dual boot and both systems work fine. The problem is that inserting a USB hard disk in either system does nothing. If I connect a USB mouse or mobile phone, they work fine, so the USB plugs are active/working and the USB hard drives that I am trying to connect work on my other laptop just fine.

I have tried to uninstall all USB-related items in Device Manager and let them reinstall upon restart, but that didn't help. The USB drive does not show up in disk management either.

The strange thing is that it is exactly the same situation on both windows. USB mice etc. work just fine and USB hard drives do not.

Any ideas on solving this problem would be great.

...Don't know if it is important, but this is a Toshiba Tecra R950 Laptop.

EDIT: I have found out that my other USB HD (Western Digital) works on this laptop, but for my StoreJet Transcend and Adata "something" does not work. All three work on another Windows 7 laptop. Sizewise the WD is in the middle at 400 GB. The StoreJet is 640 GB and the Adata is 200 GB.

share|improve this question
    
Does the drive spin up when you connect it? –  Simon Sheehan Dec 2 '12 at 5:50
    
Also are these USb 3 ports? –  Simon Sheehan Dec 2 '12 at 5:54
    
Yes I can feel the drive buzzing when I plug it in, but the blue light on the StoreJet Transcend does not come on which it does usually. I have another Western Digital USB HD And strangely that one works, so I don't know why the other two don't. I am not sure about the ports. –  Jesper Dec 2 '12 at 6:10
add comment

1 Answer 1

I found out that if I plug in a "two usb plugs to one hd plug" cable, all the drives suddenly work. So the problem is solved.

But thanks for the help anyway.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.