Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run growl notify over ssh like so ssh andrew@192.168.1.8 "growlnotify -m test" is run I get bash: growlnotify command not found however running it straight from the mac it runs fine am I missing something simple or is there a really complex reason this won't work? ps. ssh keys are enabled in both directions

edit: I logged into the mac from a remote machine over ssh and tried to run it and it ran fine so it seems to just affect the one line login and run way and DrC tried that cated the .profile to .bashrc

share|improve this question

migrated from stackoverflow.com Dec 2 '12 at 7:46

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 0 down vote accepted

What happens if you use the complete path to growlnotify?

ssh andrew@192.168.1.8 "/usr/local/bin/growlnotify -m test"
share|improve this answer
    
it works thank you very much knew it had to be something really stupidly simple like that –  CCG121 Dec 3 '12 at 19:58

Make sure that the code in your ~/.bashrc sets your path the same as .profile or .bash_profile. If it doesn't exist and the latter file doesn't produce any spurious output, then you could link them.

I'm being a bit vague as I don't recall exactly which is used on each mac version. In 10.8, my init code was in .profile and .bashrc is linked to that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.