Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed the Japanese language pack for Windows 8 but I'm finding Japanese folder names and siilar don't have the actual characters displaying, either it has square blocks or garbage like '—ö‚ÍI‚í‚ç‚È‚¢‚¸‚Á‚Æ'

Any ideas how to fix?

share|improve this question
1  
Install the language pack. Or a Japanese font –  pratnala Dec 2 '12 at 12:11
    
I've installed the language pack but with no luck –  meds Dec 2 '12 at 13:30

3 Answers 3

It's because your folder names aren't encoded in UNICODE, but SJIS.

Windows, since Vista, has Asian fonts preinstalled by default

You have to change the default encoding for Windows, but this is gonna cause a lot of trouble for all other western applications.

How to do that? (actual wording may change because I don't have Windows in English)

  1. Go to language in control panel
  2. Select "change time, date, number format" on the left
  3. Go to the "admin options" tab
  4. Press the button on the bottom to select which encoding to use with programs that don't support unicode

Be warned that most western applications will be affected (for example, even windows explorer will display C:¥windows¥system32 instead of C:\windows\system32)

If the folders are few, it's better to manually recover the name with an encoding converting tool

share|improve this answer
    
how do I change the encoding? I'm willing to see if I can put up with problems with my other applications, I only have a few I use, Photoshop, Unity3D, 3D Studio Max and Visual Studio, everything else is fair game really... –  meds Dec 2 '12 at 13:28

go to control panel view by large icons search for language click it add language go to options download and install language pack

share|improve this answer
    
The OP stated in his comment he has already tried the language pack. –  Matthew Williams Apr 28 at 16:02

Windows 8 does actually support unicode in the folder names.

There is no need to change the encoding as mentioned in other answers and there is no need to install additional language packs from the control panel.

You you have to trick windows into loading unicode font support on startup.

You can do this by creating an empty text file on your desktop.

Then rename the file to: 火.txt

Now restart your computer, this will force windows to load the correct font on startup.

You now have japanese font support for filenames.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.