Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The system clock is drifting quickly in my new Windows 8 Pro installation on a computer that ran Windows 2008 Server (Windows 7) just fine.

This is a DELL Precision M4300.


Originally I thought this was just in Windows 8. I've since put back the Windows 2008 Server hard-drive that I'd swapped out yet the problem continues. I cannot accept that this was happening before and that I just didn't notice. Over the course of a day, the clock can drift by many hours. It always seems to be slow.

I have the Internet Time sync enabled and I know how to make it happen manually.

What could be causing this, which must be a new problem? Many google search results suggest a bad CMOS battery. But I also read that Windows doesn't consult the hardware clock unless it is waking up or booting, so if the computer stays on the whole time during the drifting, I don't see how the battery could be the issue. Also, since it was not a (persistent) issue with Windows 7 I think it must be related either to the different hard drive or the different OS

(And no, it's not a virus)


I swapped back my Windows 7 drive for a few months. For the first few weeks of being back with the old drive, this new clock drift problem actually persisted! I wondered whether I had been wrong and that the drift problem had also been around in Windows 7 but I hadn't noticed. I couldn't find a solution but after a while it went away and I had a stable system clock - awake, through a sleep, reboot, not even connected to the internet for a resync it was fine.

So just today I put the Windows 8 drive back in, thinking that whatever driver or whatever was having the problem had been fixed in a patch. Well, already I'm seeing major drift again!

Is there any way that the drive itself (changing from an OCZ Agility 3 to a OCZ Vertex 4) could cause this kind of problem? I can't see how, but maybe if the drive has funny timing on the bus or something, maybe that could cause it?


I wrote to OCZ and heard back from them:

Unfortunately we have never had any cases regarding this issue with our drives. It sounds to be more of a software issue with your Windows install or a hardware issue with the system's main board. We recommend contacting Microsoft and Dell for assistance.

This is a very frustrating problem. I have to resync the clock with a time server several times in a work day.

It's not a constant drift, I don't think. Sometimes several hours can pass with no drift (rare) but within one hour it can go off by 45 minutes easily.

I'm not sure if it ever goes backward in time - that is, go to a time earlier than I synced it last. Probably not, I think that would cause major problems with file management and so on that I'm not seeing.


Here is a set of Event Log entries. When I woke up today, I noticed the clock was stuck at about 7pm last night. See how the log, which is in event order, bounces around on the time. I can't believe this system can even stay stable (otherwise) with time that jumps backwards - Surely there must be code somewhere that needs to assume a futurely direction for time! Those are the only entries from around that time.

I don't know if these errors are a cause, and effect, or just a coincidence.

Information 2/6/2013 6:58:31 PM Windows Error Reporting 1001    None
Information 2/6/2013 6:59:57 PM Windows Error Reporting 1001    None
Information 2/6/2013 7:01:15 PM Windows Error Reporting 1001    None
Information 2/6/2013 6:58:52 PM Windows Error Reporting 1001    None
Information 2/6/2013 7:00:17 PM Windows Error Reporting 1001    None
Information 2/6/2013 7:01:40 PM Windows Error Reporting 1001    None
Information 2/6/2013 6:59:22 PM Windows Error Reporting 1001    None

Log Name:      Application
Source:        Windows Error Reporting
Date:          2/6/2013 6:58:31 PM
Event ID:      1001
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Fault bucket -1469235789, type 5
Event Name: WPNConnectionFailure
Response: Not available
Cab Id: 0

Problem signature:
P1: Data Reconnect
P2: 880403f5
P4: IPv6v4
P5: None
P7: 2
P8: 244

Attached files: C:\Users\Jason\AppData\Local\Temp\wpn_3775682326159551384.evtx

These files may be available here:

Analysis symbol: 
Rechecking for solution: 0
Report Id: 1a552c3b-70b9-11e2-bed8-001e37f5f3d7
Report Status: 16
Hashed bucket: bf2d0f7d5d2d29e2ff5285f8ba408a8d
Event Xml:
<Event xmlns="">
    <Provider Name="Windows Error Reporting" />
    <EventID Qualifiers="0">1001</EventID>
    <TimeCreated SystemTime="2013-02-06T23:58:31.000000000Z" />
    <Security />
    <Data>Not available</Data>
    <Data>Data Reconnect</Data>


It's definitely jumping backward in time by an hour or so - back prior to the last reset of the clock.


Here's a post describing what seems like the exact same problem:


The old laptop motherboard failed, perhaps unrelated to this clock thing. I swapped out the identical M4300 motherboard. I didn't notice right away, but the backwards-drifting clock is now happening quite dramatically with the new motherboard as well. I never noticed this happening on the old laptop though it had the same software and drivers (as far as I casually knew), but it was used much less frequently.

I took a road trip and had intermittent connectivity. I have mitigated the issue somewhat with a new Windows Scheduled Task to sync the clock every 5 minutes and on Wake - doesn't work if the clock jumps backwards far. Without connectivity, the problem is in full effect. The clock drifted backward in time of MORE THAN A WEEK within a day or two of last sync.

This is extremely frustrating and threatens my file-syncing and git repository integrity. I'm getting a few up-votes - is this because you have the problem too? Or is it just entertaining? :-P

share|improve this question
Have you configured NTPD? I can't seem to find anything specific on it, but it would seem that your Windows 2008 installation was polling for corrections over NTPD, and now it isn't. – Ian Atkin Dec 2 '12 at 23:17
My Windows Time Service is running. Is that what you mean? – Jason Kleban Dec 3 '12 at 3:07
I think changing the battery as explained here is worthwhile. – harrymc Jan 28 '13 at 18:32
@harrymc - Thanks, but since this drift occurs while the computer is running and as Windows apparently doesn't consult the hardware clock while the system is powered on and, finally, as this issue doesn't persist in Windows 7 and on the previous hard drive (if swapped back) I feel I can rule out a low CMOS battery as the cause. – Jason Kleban Jan 28 '13 at 18:37
@ekaj - What do you want to bet it's the cat! – Daniel R Hicks Feb 15 '13 at 16:59
up vote 3 down vote accepted

same here!

As soon as the problem appeared a week ago I changed the cmos battery, but it persisted. I ran multiple virus scans with different sofwares but found nothing. sfc /scannow said the system files were ok.. and yet the clock kept freezing or jumping backwards.

then I realized the clock in the bios was freezed. I thought of an hardware problem but before calling Asrock I searched the internet and found this:

I tried an hard cmos reset (removing the battery) and the bios clock restarted!! But it stopped again when I loaded the bios settings I previously saved. So I had to reset again an manually change all settings back to how they were, and now it works.

share|improve this answer
Thank you! This is totally it. After removing all power sources and draining the capacitors by pushing the power button, mine starts again for the first boot, but the second boot it's frozen again. But this completely explains it. I guess the Windows behavior of occasionally resetting the software clock to match the hardware clock is new to Windows 8 which explains why I wouldn't have noticed the problem on Windows 7 (ONLY on cold boots, which were infrequent). [BTW, the M4300 takes a standard CR2032 (note which side gets the red vs black) then duct tape instead of the spot welds] – Jason Kleban Jan 4 '14 at 18:36
But again, I think the RTC is just fried - the new battery has no difference in behavior of the RTC. Can't get it to restart right. – Jason Kleban Jan 4 '14 at 18:36

You said that the problem occurred with "the Windows 2008 Server hard-drive that I'd swapped out".

So the conclusion is that the clock problem has nothing to do with the SSD and everything to do with the motherboard, just as OCZ Support said. Besides a loused-up clock circuit, there is only the battery left (except if you are overclocking - then everything is possible).

See for example the thread Problem with Clock in Win 8 Pro where it took some doing to convince the poster to change his CMOS battery, but finally this was the right solution.

Googling for "windows 8 clock problem" finds that Windows 8 can have heaps of funny problems with the clock. This might be because it is much more sensitive to motherboard clock problems, although it could of course also be some weird software glitch.

My advice is therefore to change the CMOS battery as well as the Internet time-server, and also to keep on patching Windows 8 (including optional updates). If necessary, use another Windows version until Windows 8 SP1 comes out (but nobody guarantees that this will fix the problem on your computer model).

share|improve this answer
Alright alright ... I just now swapped out the battery with another M4300 I have here. Same age, but I further doubt that the life phase will be so exactly the same between them. I'll let it run for a while and see if there's any more drift. I'll watch the one I swapped it with too which is on Windows 8 and isn't having a problem that I've noticed. (Don't know why I didn't think of that other machine earlier) – Jason Kleban Jan 28 '13 at 21:21
(no overclocking, but I could see a bug in Window's power management of the CPU causing this problem perhaps) – Jason Kleban Jan 28 '13 at 21:22
I wish it were that easy but my clock that was accurate 46 minutes ago when I posted is now behind by 41 minutes with the swapped battery! So the computer thinks only about 5 minutes passed. Meanwhile, the other Win8 M4300 with my original battery is running fine - not a guarantee - this one did too sometimes - but it's not looking to me like the probable cause. – Jason Kleban Jan 28 '13 at 22:10
If after the switch the suspected battery works well in the other laptop for some time, and if on Windows 8 the swapped battery shows the same symptoms, then I believe the conclusion is that there is problem with the motherboard (not related to the battery) that bothers only Windows 8. My other recommendations are still a possible solution. The only way to prove that the OCZ is the cause is by putting it in the other laptop. – harrymc Jan 29 '13 at 18:50
+11 - I think I resolved it, but I appreciate your ideas and attention. If you can explain the DNS over VPN conflict or if nobody else can, I'll give you the bounty too. – Jason Kleban Jan 30 '13 at 17:17

I believe you have a CMOS battery with low voltage like harrymc points out, I've seen this behavior of loosing time before. Do a simple test, turn your PC on and let it sit on the BIOS screen where the time shows up. Let it be for hours and see if time gets screwed up. At this level there is no OS involvement so you can rule out software. It wouldn't hurt to check if your BIOS has an update.

share|improve this answer
I'll try that, thanks. – Jason Kleban Feb 4 '13 at 12:54

I had a similar issue with Windows 8. Sometimes the clock would just stop on a specific time and would never change. At first I was thinking the CMOS battery as well, however- I then noticed that it was in fact explorer.exe freezing. Since explorer was freezing- my entire taskbar was frozen (thus the clock stopping).

While my issue describes a separate problem, the answer remains the same- I found quite a few answers in the event log. Maybe you should try peaking through your event logs around the time your clock starts drifting?

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .