Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a W2008 R2 installed on a different network (I am on 192.168.0.x - new server on 192.168.3.x)

I had trouble ping and RDP to it. I disabled the firewall to test the connection:

enter image description here

and that opened the ping feature

enter image description here

but I still can not RDP to that machine. the allow remote access is enabled

As per sinni80 idea - Here is the error message

enter image description here

enter image description here

The networks are divided by a Fortigate 60-B router - 2ndy interface for the gateway is 192.168.3.254 (and pingable from all)

  • any to any rule on both networks is in place.

As per Joe Schmoe idea - I am able to RDP to 192.168.3.1 from 192.168.3.3 (which is on the same network)

Data to add: - The servers are on a VM host, each of the servers has 2 nics

  • one is DHCP enabled into the 192.168.0.x network
  • 2nd is static IP in the 192.168.3.x

-- Further information:

  • The network 192.168.0.x - are on a domain network (active Directory)
  • The network 192.168.3.x - are grouped in a workgroup

What should I check more please?

share|improve this question
1  
Are those networks divided by router? Or they are sharing same network with different subnets? –  week Dec 2 '12 at 16:04
1  
Try to telnet from your computer into remote box on port 3389 (or whatever port remote desktop is running on if you changed it). Does this work? –  Joe Schmoe Dec 2 '12 at 17:28
    
yes, telnet works (nothing is shown) but it's a connection –  Saariko Dec 2 '12 at 17:53
1  
Maybe, make a screenshot of the error message coming from the RDP client... If it's a generic one, tough luck, but it might have one thats usable. –  sinni800 Dec 2 '12 at 17:59
1  
Another shot in the dark: can you try to remote desktop to remote server from remote network (if you have physical access to remote network)? Or ask someone with physical access to remote network give it a try? –  Joe Schmoe Dec 2 '12 at 18:03

4 Answers 4

Did you check the Terminal Licenses in your Windows 2008 R2? They should be enabled.

share|improve this answer
    
This was checked - it's ok –  Saariko Dec 17 '12 at 14:00

Please check your VM Host network setting, host firewall/network(public/private/unknown) config may be the issue.

Please test with VM Host firewall turn-off (see PS).

There is a VMware KB related to this issue.

I also solved a very similar issue here. That is for ssh connection to a VM in a Windows host.

PS: Base on comment from Oliver Salzburg, this may not work as intended. I cannot confirm as I am remote from my server now.

share|improve this answer

On the router increase the MTU to 1500 or adjust the maximum frame size on the server.

Fragmentation causes real problems for RDP, and RDP packets are oversized for most network defaults due to the extra header information added to the packets.

share|improve this answer

What is your subnet mask?

It sounds like your need to change your subnet mask from /24 to /22 (you need two binary digits to get to 3) so thats from 255.255.255.0 to 255.255.252.0

ICMP ping is a hardware broadcast request - which means that it gets broadcast-ed to all adapters on the hardware network, and your out of network server will reply. But regular network transport isn't so forgiving.

share|improve this answer
    
I don't think this has an effect in my case –  Saariko Dec 17 '12 at 14:00
    
Try it, it won't hurt your existing setup (unless you want .3. and .0. networks traffic seperated) –  JERiv Dec 18 '12 at 18:04
    
(it would create a new broadcast address which would include both subnets) –  JERiv Dec 18 '12 at 19:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.