Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I did setup a nfs share on my debian 7 server and been trying to mount it on a windows 7 machine.

I've tried the following:

C:\Users\David>mount \\192.168.178.240\backups Y:
Network Error - 53

Type 'NET HELPMSG 53' for more information.


C:\Users\David>mount 192.168.178.240:/backups Y:
Network Error - 53

Type 'NET HELPMSG 53' for more information.

When I run NET HELPMSG 53 it tells me that the network path was not found.

C:\Users\David>showmount -e 192.168.178.240
Exports list on 192.168.178.240:
/backups                           192.168.0.0/255.255.255.0

As you can see it does exists. The IP address of the windows 7 machine is 192.168.137.252 so this is in the right subnet.

/etc/exports is as following:

root@debiansrv:~# grep backups /etc/exports
/backups 192.168.0.0/255.255.255.0(rw)
share|improve this question
    
tried the same as above on a windows server 2008 R2 (IP: 192.168.178.230). Same error(s) – David Dec 2 '12 at 20:09
    
what happens if you try to use net use instead of mount? – Ƭᴇcʜιᴇ007 Dec 2 '12 at 22:52
1  
Found the solution. besides the rw option I had to add "insecure" – David Dec 10 '12 at 12:47
1  
Nice to hear! You should expand that solution a little and add it as an answer for future visitors (it's allowed :) ). – Ƭᴇcʜιᴇ007 Dec 10 '12 at 19:47
1  
Will try. English is not my native language as you might have noticed.. Also had to map the uid and gid from the anonymous user to make the write and read permissions work. – David Dec 11 '12 at 19:07

Try putting a "*" instead of specifying the drive name.

Error 53 also return when it cannot allocate the drive name as well.

Also, mount exactly as the showmount -e output show, eg:

if in your export say /home as the export, do not mount /home/[something], window wont understand.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .