Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed the CentOs server on the VM and I am using a Host Only Interface, and have set the IP address of the host and Centos. I am able to SSH from the terminal of the host to Centos but I am not able to access the test website from my browser.

Can anyone tell me what can be done to access the test website?

share|improve this question
Try to look at netstat -l -n, if your web server is listening on port you want. Try to telnet webserver port from your host. – week Dec 2 '12 at 20:31
up vote 1 down vote accepted

Don't use Host-Only networking. This completely isolates the virtual machine from the Internet and provides connectivity only to the virtual machine host.

Instead, use bridged or NAT networking.

Also, CentOS has a built in firewall and it's turned on by default. You need to disable it or run system-config-firewall-tui as root to reconfigure it.

share|improve this answer
Thank you Micheal, but I do not need the internet access, I just want to access the test website from the host through the browser using the IP address that I have set to the Guest in the VM. – Amit Nandan Periyapatna Dec 2 '12 at 20:28
I've updated my answer. Sounds like you may have a firewall issue. – Michael Hampton Dec 2 '12 at 20:30
There is no firewall wall tui on my centos, all i can find is the system-config-network-tui. Is there any other way that I can disable the firewall? One small doubt, since I am able to ssh, doesn't it meant that the firewall has been disabled? – Amit Nandan Periyapatna Dec 2 '12 at 20:33
You probably need to install it, then: yum install system-config-firewall-tui – Michael Hampton Dec 2 '12 at 20:36
Is there any other way that i can disable the firewall? – Amit Nandan Periyapatna Dec 2 '12 at 20:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.