Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I boot up my ubuntu server, it cannot connect to my wireless network anymore. It says "waiting for network configuration" for 60 seconds, boots up, but no wireless.

I suspect it's because of the following reasons.

I used to connect to a wireless connection named 2WIRE555, password: 123abc But then I upgraded my connection and my new wireless connection was named 2WIRE444, password:111111

Being lazy, I simply renamed 2WIRE555 to 2WIRE444 and changed the password accordingly. I was hoping this would work but ever since then my network configurations is messed up.

So back to the issue, how do I reset my network configurations for my Ubuntu 11.10 server?

share|improve this question

migrated from Dec 2 '12 at 21:14

This question came from our site for professional and enthusiast programmers.

i fixed it by editing two files: /etc/resolv.conf and /etc/network/interfaces

i changed the nameserver of the old file from to

i changed the /etc/network interfaces from

auto wlan0
iface wlan0 inet dhcp
    wireless-mode managed
    wireless-essid 2WIRE555
    wireless-key1 123abc


auto wlan0
iface wlan0 inet dhcp
    wpa-ssid 2WIRE444
    wpa-psk 111111

can anyone please explain to me the differences and why it worked?

share|improve this answer
In old settings you used WEP encryption and in new config you are using WPA encryption. – week Dec 2 '12 at 22:15

The first example is for a WEP encrypted device.

wireless-essid 2WIRE555

The second is for a WPA encrypted device.

wpa-ssid 2WIRE444
share|improve this answer

You must log in to answer this question.