Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Somewhere in the recent past something has changed on my Windows Vista 64 bit desktop to where I can't delete certain folders. I had started cleaning out some old files prior to starting backing things up, but it seems I can't delete things that I should be able to...

It seems that folders that are left behind as part of any install process, some quite a while back, have a read-only bit set on the folder properties, and I can't delete them. I change the properties, hit 'Apply', and exit the Properties dialog... and I'm right back where I started. Upon inspection, the folders have the read-only bit set again.

Any ideas/suggestions - beyond blowing away Windows entirely? (if it wasn't for certain games, I would, trust me!)

share|improve this question

2 Answers 2

Run cmd.exe as a Administrator and use rmdir /S c:\damnfolderdie\ or if you want gui run from same cmd.exe notepad.exe instead, select open file and delete that folder via open dialog.

It's kind of workaround, but it's working so...

share|improve this answer
    
Yeah... still not working. This deletes the files inside the problem folders, which is a step in the right direction... but the folders are still there... all of them. –  memilanuk Dec 3 '12 at 1:34
    
Sorry, my fault it's `rmdir /s c:\damnfolderdie`. –  week Dec 3 '12 at 1:41
    
Still not working... now it's telling me 'Access is denied'. –  memilanuk Dec 3 '12 at 2:12
    
Then it's a time for Unlocker, it's an utility which can delete files and folders which are opened by another programs. –  week Dec 3 '12 at 2:39

Another option, also semi-work around, would be to use a registry tweak to "take ownership".

I assume you are an admin, and as such - you can follow this guide to get you there.

All you need to do is download the reg files, double click to install, say yes, and then right click on any folders that you cannot delete, select "Take Ownership" and then you should be free to do your bidding.

share|improve this answer
    
Yeah... already tried that. Doesn't work. Gives exactly the same results as before - tells me I don't have permission to delete those files. –  memilanuk Dec 3 '12 at 1:39
    
Very odd. Sorry to provide a useless answer, I didn't see you say anything about it above. –  nerdwaller Dec 3 '12 at 1:47
    
NP... I hadn't mentioned it because nothing had happened and I'd forgotten about it. –  memilanuk Dec 3 '12 at 2:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.