Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently installed Debian on my laptop and am now dual-booting it with Windows 8. Windows 8 shows following problems: after spending some time setting up Debian and booting up Win again, I noticed that no soft power off options worked on my Windows 8. By that I mean, I can not hibernate, sleep or shutdown. The GUI doesn't give any notification of failure. What happens is, screen goes blank (like it should), but doesn't power off; after moving the mouse, it lights back up, just to see that it's at the log on (technically unlock screen, because it doesn't log the user out).

When using shutdown /h, everything happens like explained above. After failed attempt to hibernate, I unlock the workstation and this is what the cmd console looks like:

C:\Users\Domas>shutdown /h

The requested system device cannot be found.(15299)

C:\Users\Domas>

I have been googling for the past week or so to no avail. I ask your help in diagnosing the problem. What information could I provide?

Cheers, Dom

EDIT:

Additional notes: Apparently, shutdown /s /f shuts down successfully. Though, same doesn't work for hibernation. And System Event Logs don't provide any info.

share|improve this question
    
And this is happening regardless of how you end up Debian session? I mean even when you halt properly without hibernating. – week Dec 3 '12 at 1:24
    
Does 'shutdown /f /s /t 0' (without the single quotes) work? Are there any errors listed in the System Event log? – Mark Allen Dec 3 '12 at 1:26
    
Yes, this happens regardless of whether I hibernate or shutdown in Debian. – Dominykas Mostauskis Dec 4 '12 at 0:18
    
Mark, System Event Logs show nothing. However, shutdown /s /f shuts down successfully. Hibernating with /h still doesn't work. – Dominykas Mostauskis Dec 4 '12 at 0:31

Go to Control panel -> Power options
Click on the Choose what power buttons do in the left side menu.
On the top of the window you should find an option -
Change settings that are currently unavailable click on that ,
scroll down and select Hibernate in shutdown settings.

This is what I did to re-enable hibernate on my machine , the old windows 7 tricks don't seem to work

share|improve this answer
1  
Unfortunately, doesn't help. This is a bit irrelevant as well. As far as I can tell, my problem is caused by installing Debian, due to caused reorganization on whatever level, Windows feels lost when a shutdown is requested. That's the 5 year old's version. I need help understanding what's actually happening. – Dominykas Mostauskis Dec 6 '12 at 16:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .