Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm all set up with a spiffy Arch installation in a virtual machine, and now I want to turn it into a live ISO. When I heard about larch, I thought it would be the perfect tool to turn my existing installation into something I could distribute.

However, I can't get larch to install properly. I followed the installation instructions on the website, which said to download and run the larch-setup script. When I run it, though, it installs the larch profiles and libraries but doesn't install the executable programs.

Here's a screenshot of the errors I get when larch-setup tries to install the executables.

Screenshot of what happens when I run larch-setup

I'd greatly appreciate any clues to what is going wrong here, or suggestions for alternative ways to turn my customized Arch installation into an ISO! Thanks!

share|improve this question
Looks like it is looking to the wrong place for something it needs (specifically tmp/usr/bin), which doesn't exist by default in anything... You may need to download the script and edit it to view the right thing before it executes. I will take a quick glance at it too.. – nerdwaller Dec 4 '12 at 21:35

The issue is occurring in this section of the script:

for s in $( ls tmp/usr/bin ); do
    p=$( readlink tmp/usr/bin/${s} )
    d=$( dirname ${p} )
    ln -s larch0/$( basename ${d} )/$( basename ${p}) ${s}
rm -rf tmp

I try running those individually and get errors, so it seems to me that the symlink is the wrong approach since "tmp" is getting nixed below.

Also, readlink is not echo-ing back anything when I try that. Probably because it is not printing back values, then killing dirname and everything below. Maybe replace that with (though, this is dirty since I don't fully know where the next stuff looks):

mkdir -p larch0/tmp/usr/bin
mkdir -p larch0/usr/bin
cp tmp/usr/bin/* larch0/tmp/usr/bin/
cp tmp/usr/bin/* larch0/usr/bin

That just copies the same files to those two locations since I don't know what the next script really wants. I bet it is just larch0/usr/bin logically, but whatever.

share|improve this answer
Thanks for your detailed answer. I've actually given up on larch since contacting the developer, who said he doesn't maintain it anymore and that it probably won't work with new Arch installations. I'm now trying to build my distro with archiso, but I'm still having problems. I'll save those for another post. – strangeronyourtrain Dec 4 '12 at 23:10
No worries, glad I didn't rewrite the whole thing like I was considering since I pondered doing this as well. – nerdwaller Dec 4 '12 at 23:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .