Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I’m not using a normal Apple Keyboard on my Mac. It’s a standard ISO keyboard with a German Layout. Unfortunately this keyboard is not supported by OSX by default. So some keys are not working right. Apple uses some different layout for special characters. So I created my own keyboard layout and installed it on OSX. This is working just fine. I have a symbol in the menubar to switch the layout. This is necessary because I also have the internal keyboard of the MacBook that is using the Apple layout.

The problem is that my layout works fine for most applications. But there a some that keep switching the layout to the Apple default one. For example the Apple Mail App or Parallels Desktop. This drives me nuts: Some applications have a different layout.

In the system setting there is an option for the input source. I set it to “Use the same one in all documents”. But it still changes the layout in Mail. The funny thing is that if Mail is active I can’t switch the keyboard layout manually. I can select it, but it just won’t switch it.

Hope somebody can help me.

share|improve this question
I’ve got the same problem. Only with Mail, all other applications use the right keyboard layout. What did you use to create the custom keyboard layout? I used Ukulele – Jakob Stoeck Apr 3 '13 at 15:05

1 Answer 1

If the keylayout is in ~/Library/Keyboard Layouts/, try moving it to /Library/Keyboard Layouts/. It normally enables using keyboard layouts in password dialogs and the login window.

You can also disable the default input sources by editing the HIToolbox plist.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.