Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I followed the sublime text 2 command line tool installation feature some time ago and it was working just fine. However, it's not working anymore.

When I type subl in the command line, it returns nothing at all. When I cd into a dir and subl ., nothing is returned either.

I tried removing the subl file in my bin and reinstalling but it's still not working.

I'm running on OSX btw. Thanks a lot guys.

share|improve this question
2  
When you say "nothing at all", what exactly do you mean? Do you get an error message or simply nothing? Did you change something in between? Where have you put it exactly (there are quite some bin directories all over the place in OS X)? What's the output of ls -la $(which subl)? Does it work if you run /Applications/Sublime Text 2.app/Contents/SharedSupport/bin/subl? –  slhck Dec 3 '12 at 12:01
    
dont you have to use it like: subl somefile/subl . ? –  sanny Sin Dec 3 '12 at 13:18
    
@sannySin No, you use it like subl <directories> or subl <files>. –  slhck Dec 3 '12 at 13:24
    
@slhck thanks for the response. When I enter the command, it won't return an error. It will go to the next line but sublime text won't startup. I've tried with sublime open and closed. –  Hassanin Ahmed Dec 4 '12 at 2:05
    
Okay, interesting. Could you also please answer all of the questions I've posted, ideally by editing your question and adding more info? Especially, what about running /Applications/Sublime Text 2.app/Contents/SharedSupport/bin/subl standalone? Have you rebooted your system in between, or have you tried it on another user account, maybe? Or uninstalling Sublime? –  slhck Dec 4 '12 at 7:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.